4

This is a bug which I've found littered across very many forums, with a plethora of advice (none of which has worked for me).

So far, the things to try (in no order beyond discovery online):

  • make sure the kernel is allowed to boot by either:
    • a.sudo mokutil --import /etc/pki/akmods/certs/public_key.der to import the key for secure boot
    • or b. disabling secure boot in UEFI
      • check mokutil --sb-state or dmesg | grep -E 'secure|nvidia' to verify.
  • disable windows fast boot (there's also a UEFI fast boot, if you don't know which is which try this suggestion last)
  • Reinstall
    • sudo dnf remove \*nvidia\* to remove everything
    • sudo dnf install akmod-nvidia to reinstall
  • sudo akmods --force to make sure things are being built for the current kernel
    • uname -r to verify the kernel matches the one you're running
  • cat /var/log/akmods/ to see if there's any clues in akmods
  • modinfo -F version nvidia to verify driver is being loaded
  • lspci -v | grep "VGA controller" to get the ID of your driver (eg "0a:00.0")
  • cat /proc/cmdline to check that your boot is good
    • should have details about blacklisting novaeau

4 Answers 4

2

In my case, when I got the message NVIDIA kernel module missing. Falling back to nouveau it was because I had installed the wrong NVIDIA drivers for my old graphics card.

In other words, to solve this I followed this guide RPM Fusion - HowTo - NVIDIA.

In a nutshell, this is what I did:

1.- Uninstalling the wrong NVIDIA drivers. In my specific case, I knew the specific dnf transactions which installed those recently and I rolled them back.

2.- Find the exact model of my NVIDIA card:

# lspci | grep -e VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)

3.- Visit NVIDIA Support chips website and find which driver had support for my exact GPU model; 470xx in my case.

4.- Go back to the previous RPM Fusion HowTo guide and followed the steps for installing that driver.

5.- After the reboot, the message disappeared.

I hope this helps.

2

I had this issue today after upgrade to fedora 39. Looking into the modules folder, nvidia module is there. Turns out nvidia module is not listed in module.dep. so to fix my issue, just run

$ sudo depmod
$ sudo dracut -f # perhaps this as well

I don't know why the upgrade process missed to regenerate dep for nvidia modules. I have zfs modules installed as well, which was regenerated in module.dep and works okay.

1

For me the issue was that my GPU is old and I needed to change to another version:

$ sudo dnf remove \*nvidia\*
$ sudo dnf install xorg-x11-drv-nvidia-470xx akmod-nvidia-470xx
1

So, I was having the same problem, tinkered a lot with many things and importing the secure boot key was the solution, after runing sudo mokutil --import /etc/pki/akmods/certs/public_key.der, rebooting and doing the proper steps on the MOK boot, it worked just fine, no problems... I can't really help you more than this I'm not knowledgeable enough to do so.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .