I've been trying to get my wireless working for two weeks now. I have 1814:3290 wireless card. I am on Linux Mint 14 64-bit. I have tried all the suggestion on here:




I updated my kernel to 3.8.5-030805-generic. The first thing I tried was compiling the drivers (using original kernel 3.5.0-17-generic). When I compiled and installed, my wireless worked, but, I kept getting kernel panics every time I logged in. So I modprobe -r rt3290sta. After that I tried updating the kernel to the one I have now and copying the bin file. The kernel saw the wireless card but it was not active or anything. I checked rfkill and nothing was blocked. So then I tried compiling the drivers again after make clean first. Now when I try to compile the drivers I get this:

/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:43:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rt2860_remove_one’
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:44:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rt2860_probe’
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:63:46: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__devinitdata’
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:85:17: error: ‘rt2860_pci_tbl’ undeclared here (not in a function)
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:86:17: error: ‘rt2860_probe’ undeclared here (not in a function)
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:88:5: error: implicit declaration of function ‘__devexit_p’ [-Werror=implicit-function-declaration]
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:88:29: error: ‘rt2860_remove_one’ undeclared here (not in a function)
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:292:24: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rt2860_probe’
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:463:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rt2860_remove_one’
/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.c:71:1: error: ‘__mod_pci_device_table’ aliased to undefined symbol ‘rt2860_pci_tbl’
cc1: some warnings being treated as errors
make[2]: *** [/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/../../os/linux/pci_main_dev.o] Error 1
make[1]: *** [_module_/home/dis/Downloads/DPO_RT3290_LinuxSTA_V2600_20120508/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.8.5-030805-generic'
make: *** [LINUX] Error 2

Everything is up to date also. I'm not sure where to go from here. Maybe I should downgrade my kernel to 3.6 or 3.7?

Edit: So I downgrade my kernel to 3.7.2 and recompiled the drivers. The kernel sees my wireless card but doesn't really seem to work and everything freezes. Going to try kernel 3.6.

Edit2: After more testing I found out that 3.7.2 and 3.6.11 both give me kernel panics after installing the wireless driver.

Edi3: I installed 3.7.11 and compiled and installed the wireless drivers. Wireless worked for 3 seconds and then had a kernel panic.

1 Answer 1


I've bought a HP envy Dv7. My Wireless was not working with native module and I was goting kernel panic with proprietary ralink rt3290 module. So, I've found a solution at an Russian site (http://forum.ubuntu.ru/index.php?topic=217802.0)

sudo su
apt-get install linux-headers-`uname -r` build-essential --force-yes -y
cd ~
wget -c https://www.kernel.org/pub/linux/kernel/projects/backports/2013/03/15/compat-drivers-2013-03-15.tar.bz2
tar xvf  compat-drivers-2013-03-15.tar.bz2 | tail
cd compat-drivers-2013-03-15
scri*/dri* rt2x00
make install

So, blacklist your rt3290 module, "un-blacklist" both rt2800pci and rt2x00pci and reboot. Everything is working fine to me now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .