1

When running Banshee from the terminal, after I click on a song, a little x appears next the song title and I get this output:

GStreamer-CRITICAL **: gst_element_query: assertion `GST_IS_ELEMENT (element)' failed

As Banshee starts, I also get this output (it may not be related, I have no idea):

[Warn  17:57:43.999] Failed to start DAAP client - System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running. (in `Mono.Zeroconf')

I've tried updating gstreamer, but that didn't help. I'm currently using Gnome3. Anyone know what's going on?

1

Try testing other gstreamer-based media player (i.e. Totem, Rhythmbox), and if they don't work either (for the same files you tried to play with Banshee) then you have a broken GStreamer installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.