2

I decided to do a LAMP install to start getting more familiar with it (as our company is moving more towards nix these days). Everything went great and PHPMyAdmin, MySQL, Apache/PHP all seem to be running fine.

The test .php files I uploaded to the /var/www/html directory worked fine, but after extracting a tarball with a folder inside of it to that directory, I receive a 403 Forbidden error when attempting to access it.

I have tried...

  • Setting SELinux to permissive mode
  • CHMOD directory to 777 for testing. It fixes the 403 error but all the php files in it are just white pages
  • Setting a in the Apache configuration

The httpd error_log reports (before I set it to permissive)...

SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
0

You can try to run:

restorecon -r /var/www/html

0

It is possible that you have a .htaccess file inside that archive, which causes that error. If it's default configuration, then you should have more information in error log about 403.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.