I have a pretty severe issue with KDE Plasma on Fedora 35.

I have a laptop with 3 external screens connected. The laptop lid is closed (in case this is relevant) 2 of them are 4k monitors that I use at 2k resolution and is a 1080p monitor.

When being connected to that docking station I have typically 1 of two cases:

  • The taskbar on my main screen is missing and I have good FPS
  • The taskbar on all screens are present but I have around 0.25-0.5 FPS for windows (the cursor moves smoothly but all applications only update around once every 2-4 seconds. Also applies to moving around windows and resizing them)

A little while back I found out that you can restart KDE with this command:

killall plasmashell; kwin --replace & kstart plasmashell > /dev/null 2>&1 & disown

Now with diconnecting and reconnecting my docking station and running this command, typically eventually I get a state where I have all my taskbars and decent FPS, however when this happens the background of one of the 3 screens is blank and rightclicking it brings up no context menu like with the others.

I already tried completely resetting my config by deleting all file that match ~/.config/plasma*. This made no difference.

Also this sadly isn't a clean instalaltion of Fedora 35, but one that was upgraded over time from Fedora 31. Though this issue began only during Fedora 35. Initially after the upgrade everything was fine. Then I had to leave the office for a few months and when I came back the lags happened, and all the while all I really did was keeping up with updates.

I'm really at a loss here. Additionally I can't just reinstall the machine for various reasons I'd really not like to get into here. I also tried Wayland, but that doesn't detect my external screens properly, so it's no use for me at the moment.


  • KDE-Plasma: 5.24.4
  • KDE-Frameworks: 5.91.0
  • Qt: 5.15.2
  • Kernel: 5.18.11-100.fc35.x86_64
  • Graphics Platform: X11


Here is my graphics cards info:

sudo lshw -c video
       description: VGA compatible controller
       product: WhiskeyLake-U GT2 [UHD Graphics 620]
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:138 memory:d7000000-d7ffffff memory:b0000000-bfffffff ioport:3000(size=64) memory:c0000-dffff
  • Video driver in use ? (if nvidia-proprietary, version ?) How do you know about fps ? Results after disabling compositing ? (system settings / Display & monitor / Compositor)
    – MC68020
    Commented Jul 22, 2022 at 20:45
  • Have a look at this: bbs.archlinux.org/viewtopic.php?id=274732 It may help, as by the sounds of it you have a discrete NVIDIA gpu on your laptop
    – djmonki
    Commented Jul 25, 2022 at 4:37
  • Could that be a result of power-saving due to the closed lid in any way? Did you try with open lid also?
    – gerhard d.
    Commented Jul 25, 2022 at 8:13
  • @MC68020 I added the video card + driver info. My apologies for forgetting that. I know about the FPS by counting the seconds between frames (frames of the windows, the cursor moves smoothly, but windows take forever to produce the next frame). To disable the compositor, you mean unchecking the first checkbox (at start) and restart the machine?
    – BrainStone
    Commented Jul 25, 2022 at 8:35
  • A/ Yes for unchecking the first checkbox. (Machine restart should not be necessary. At most a restart of kwin.) B/ I suggest you ask kde plasma to display the fps itself (system settings>Workspace behaviour>Desktop effects | Tools | Show fps. C I would also strongly suggest that while being there, you disable all other desktop effects.
    – MC68020
    Commented Jul 25, 2022 at 8:46

2 Answers 2


Not yet standing as an answer, much more a guide to diagnose your troubles :

O/ Start having a reliable way to objectively measure the fps : since I believe mainly concerned with opengl response, glxgears -info (from the mesa-progs package) could be a starting point as well would be the kde-plasma destop effect "show fps" (system settings > Workspace behaviour> Desktop effects | Tools | Show fps.) while running whatever fps demanding task.
Note that many games / applications offer the possibility to report about fps… if running some of these, this could rightly be preferred.

A/ Start your experiments after having disabled all desktop effects : Go into system settings > Workspace behaviour> Desktop effects and disable everything. (apart from the show fps effect if selected following 0/ of course)
The rationale being that history shows a considerable amount of display problems related to desktop effects (particularly with downloaded ones)
If happy with everything then stop there and isolate those of the desktop effects directly linked with the problem.

B/ Disable compositing. (system settings / Display & monitor / Compositor )
I don't know which version of kwin_x11 was shipped as part of your Fedora-31 but significant changes were achieved starting from kwin-5.21 around compositing and particularly in the sync to vblank management.
This is likely to cause troubles if not correctly tuned, particularly if your screens do not get identical refresh rates

  • Turns out it was compositing. Sorry for the late answer from my side.
    – BrainStone
    Commented Feb 6, 2023 at 9:21

there will be just too much that can go wrong there.


you will have better luck by searching through known past issues and finding one that you think might be your case, or trying them all.

such as this one:


otherwise, reducing the 4k to 2k or even 1k might make your fonts bigger, but your old self will thank you for sparing your eyes!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .