While trying to save a file out of Nano the other day, I got an error message saying "XOFF ignored, mumble mumble". I have no idea what that's supposed to mean. Any insights?

  • 3
    CTRL-S works (as save file) in Ubuntu 18.04, but not in 16.04. Commented Apr 16, 2019 at 0:08
  • 1
    Nice catch! Looks like it was added in v2.9.0! Commented Apr 16, 2019 at 16:06

3 Answers 3


You pressed Ctrl+S instead of Ctrl+O to save the file. Ctrl+S is an old flow-control key combination to pause the transmission, and stop scrolling, of data to a terminal (internally, the code sent is called XOFF). Ctrl+Q (XON) is the complement to start transmission and resume scrolling.

Nano ignores these code since it doesn't use scrolling. The muttering is likely a result of its frustration that you didn't remember to use Ctrl+O to save.


You typed the XOFF character Ctrl-S. In a traditional terminal environment, XOFF would cause the terminal to pause it's output until you typed the XON character.

Nano ignores this because Nano is a full-screen editor, and pausing it's output is pretty much a nonsensical concept.

As to why the wording is what it is, you'd have to ask the original devs.

  • pausing its output is not nonsensical if you are using 'software flow control' from a host PC on a physical terminal and are using xoff to prevent a buffer overflow when redrawing the screen (paging down, etc). But usually that'd be handled host-side and not user-side, I suppose.
    – Wyatt Ward
    Commented Jan 23, 2016 at 20:16
  • Ironically, I mostly use CTRL-X to save and quit in one go, and that always makes me confuse the X and the XOFF bits.
    – aalaap
    Commented Jun 6, 2016 at 10:42
  • 22
    I believe the "mumble mumble" is a soft prank to Windows users, where CTRL+S is the save hotkey. Welcome to Unix
    – DarkCygnus
    Commented Nov 18, 2016 at 20:45
  • 2
    Ctrl-S is save in Nano too, but only in recent versions.
    – Timmmm
    Commented Apr 26, 2019 at 13:41

This is an ancient issue that is solved in modern Linux machines. Still, since Windows' WSL installs Debian 9 by default (it's past mid-2022!!), and the latest nano version doesn't come with Debian 9, it is very much possible to get this nonsense error from nano in a WSL shell on windows.
The right solution on WSL is to upgrade Debian 9 to Debian 11 (this is the latest version as of the time I'm writing this) which is entirely straightforward. Please note, these instructions are meant to be run on a newly installed Debian WSL. If you have software installed on your Debian, it will get complicated!

  1. Use sudo nano /etc/apt/sources.list to edit the apt's sources.
  2. Make sure its content is exactly as this:
deb http://deb.debian.org/debian bullseye main contrib non-free
deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
  1. Now clean, update, full-upgrade and autoremove using the apt.
    During the full-upgrade, apt will ask for your permission to restart services. Select YES.
sudo apt clean
sudo apt update
sudo apt full-upgrade -y
sudo apt autoremove -y

You may now confirm you're running the Bullseye by running cat /etc/os-release.
Now, the Ctrl+S works in nano and you may use modern nano configuration commands in your ~/.nanorc.

** This was all taken from https://linuxhint.com/start-debian-gui-windows-10-wsl/
** I use wsl --install -d Debian to install Debian.

  • Sorry, but this does not seem to address the current issue ("I have no idea what that's supposed to mean. Any insights?").
    – Kusalananda
    Commented Aug 11, 2022 at 15:53
  • If you use nano on a Debian in WSL, you will get the same error as the OP. This is because nano is old and can't be upgraded. I have explained the procedure to upgrade Debian and nano, which will make the Ctrl+S work as it should. This post is the first entry in Google's search about "XOFF ignored, mumble mumble," whose reason is already explained here. I have written this post to help solve this problem in 2022.
    – Achilles
    Commented Aug 11, 2022 at 16:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .