I am running Devuan 3.1.1 32-bit (Debian based) with kernel 4.19 on an old PC and trying to install proprietary Nvidia drivers. The latest version of the driver for the FX 5200 is version 173.14.39.

I have tried two methods for installing Nvidia drivers on my machine. The first is using the .run installer file directly from Nvidia's website. The second is using a nvidia-173_*.deb package file from Ubuntu package archives and installing it with dpkg.

I made sure to blacklist the nouveau driver in /etc/modprobe.d/ by creating a file named blacklist-nouveau.conf and putting blacklist nouveau and options nouveau modeset=0 in that file.

.run file method

I installed these packages as a prerequisite for running the installer: linux-headers-4.19.0-21-686 make automake gcc g++. I also installed some extra packages because in some installation instructions for Nvidia drivers I came across while searching for a solution said to install them and I figured it can't hurt to have them: pciutils elfutils libglvnd-dev build-essential.

I downloaded the .run file from here and ran it with sudo sh NVIDIA-Linux-x86-173.14.39-pkg1.run.

The installer runs for about 2 minutes before giving this error in /var/log/nvidia-installer.log.

The error log file says I should run make oldconfig && make prepare on the kernel source to fix the issue, so I tried running make oldconfig && make prepare in every subdirectory in /usr/src, the directory which contains linux-headers-4.19.0-21-686 and linux-headers-4.19.0-21-common. Running in any of these directories gives me this error;

scripts/Makefile.build:45: scripts/basic/Makefile: No such file or directory
make[1]: *** No rule to make target 'scripts/basic/Makefile'. Stop.
make: *** [Makefile:484: scripts_basic] Error 2

and the Nvidia installer still fails.

dpkg method

I added deb [allow-insecure=yes] http://us.archive.ubuntu.com/ubuntu/ trusty main to /etc/apt/sources.list to access Ubuntu 14.04 Trusty Tahr software repositories because the nvidia-173 driver is in those repositories. (yes I am aware that this is very dumb but I am trying everything)

I ran sudo apt install nvidia-173 and received this error:

Package nvidia-173 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'nvidia-173' has no installation candidate

I found an archive of a nvidia-173_*.deb installer file and downloaded it.

I ran dpkg -i nvidia-173_173.14.39-0ubuntu4_i386.deb and it gave an error saying it had these dependencies that needed to be installed; dkms acpid xorg-video-abi-15 and "broke" apt, so I "fixed" it by running apt --fix-broken install.

dkms and acpid installed, but when I tried to run sudo apt install xorg-video-abi-15 it gave me this error:

Package xorg-video-abi-15 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'xorg-video-abi-15' has no installation candidate

I was unable to find an archive of xorg-video-abi-15.

When I tried to run dpkg -i nvidia-173_173.14.39-0ubuntu4_i386.deb it gives me this error:

dpkg: dependency problems prevent configuration of nvidia-173:
 nvidia-173 depends on xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14 | xorg-video-abi-15; however;
  Package xorg-video-abi-11 is not installed.
  Package xorg-video-abi-12 is not installed.
  Package xorg-video-abi-13 is not installed.
  Package xorg-video-abi-14 is not installed.
  Package xorg-video-abi-15 is not installed.

dpkg: error processing package nvidia-173 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

So, any ideas?

1 Answer 1


I have the misfortune to be very well versed in this issue.

The first, and correct, solution, is to use nouveau free driver.

Legacy means legacy, and EOL means EOL

While you didn't list your system specs or Xorg version, here's the basic cutoff points of 173.14.39 (the last of the 173.xx.xx series):

  1. Last X.org version supported: 1.15
  2. Last kernel supported: 3.12

These are not negotiable items, if you run newer than X.org 1.15 or kernel 3.12, you cannot use the 173.xx driver, period.

So there's no need to waste your time trying to get something that can't run in the modern era running.

the FX 5xxx cards were EOL around 2005. While nvidia does a quite decent job supporting their legacy cards, support tends to run out somewhere between 5 and 10 years, depends.

304.xx series card non free drivers maxed at 4.13 kernel and xorg 1.19. Those are also EOL.

340.xx maxed at 5.4, and are also EOL. Those were made up to 2013, and I think had about 7 or 8 years? of support.

Short story is simple:

If you buy a reasonably modern radeon (1+ GiB ram) or amdgpu supporting AMD card, used, you will be happy, but if you try to run nouveau, you may not be as a happy because it's buggy and inconsistent. I tried it for a while but too much stuff was glitchy, crashed, failures to wake from suspend, etc.

I ran nvidia until 340.xx went EOL with current kernels, then bought some used AMD cards and haven't had any graphics issues since then. Those were well spent $20 per card in my opinion.

Using Nouveau

Your old hardware is more likely to have ok nouveau support than newer cutting edge stuff, but it really varies, nouveau is entirely reverse engineered by non nvidia people, who have done good work, but they don't have specs so it's very difficult for them.

The real question is why a Devuan user even thought trying to use EOL legacy non free nvidia drivers was even an idea worth trying in the first place.

Non free means something, it means nobody has access to the source code of legacy eol drivers, so they can't be updated or fixed or patched, they are binary blobs, period. Sometimes you can do light patching if you know how to do it, but you can't make a kernel or xorg that isn't supported at all work.

  • System specs: Pentium 4 1.6 GHz 512MB PC133 SDRAM Nvidia GeForce FX 5200 Xorg is version 1.20.4 The graphics card is the newest thing in the machine Thanks for the help, this pretty much explains everything I would want to know
    – pybear404
    Jul 16 at 21:59
  • Like I said, I have the misfortune to be far too well versed in this specific issue. Try nouveau, if it works, you're good, if it doesn't, get an AMD, or ATI maybe for that generation, used, and it will probably work fine. You want something that supports the radeon driver, I assume that's an AGP video slot.
    – Lizardx
    Jul 16 at 22:03
  • ps, if my answer was complete, accept it, so I get the bonus points, lol.
    – Lizardx
    Jul 16 at 22:07
  • An upvote for me, because, yeah, each time I've tried nouveau it was buggy as hell. Jul 17 at 3:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.