0

I am using btrfs (which seems integral to the question).

Upon recovering with timeshift and rebooting, I am encountering the following error

[Failed] Failed to mount /home.
[Depend] Dependancy failed for Local File Systems
You are in emergency mode. After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or "exit" to default mode.

Obviously, Control-D, rebooting and default mode etc. do not work. I tried timeshift --restore and I get the following error.

enter image description here

It says "Found stale mount for device /dev/nvme0n1p2 at path /run/timeshfit/837/backup. \n Unmounted successfully. \n E: Failed to remove directory. \n Ret=256".

I think the problem is, that it can not mount /dev/nvme0n1p2 to /home. But I am not sure how to fix it.

Would really appreciate some help sad

Cheers.

P.S. here is my /etc/fstab output, when I log in as root (after emergency boot) enter image description here I have a feeling, that typing

mount /dev/nvme0n1p2 /home

might fix it, but I am afraid it might just wipe the drive or something...

2

2 Answers 2

2

SOLUTION: upon entering the root (just type password in the emergency mode) I edited /etc/fstab * There I removed the bits where it said subvolid=xxx$. E.g from

UUID=xxx-yyy-zzz  /home  btrfs  rw,noatime,compress=zstd:3,ssd,space_cache,commit=120,subvolid=257,subvol=/@home 0 0

to

UUID=xxx-yyy-zzz  /home  btrfs  rw,noatime,compress=zstd:3,ssd,space_cache,commit=120,subvol=/@home 0 0

Save and reboot.

Fixed

  • Technically, I had typed mount /dev/nvme0n1p2 /home and then I used sudo vim /etc/fsbat. But it should be the same result, unless I am gravely mistaken.

USE ALL AT YOUR OWN RISK :) But it worked fro me.

Much thanks to @Albator78 on the Arch subreddit: https://www.reddit.com/r/archlinux/comments/qhb13t/comment/hieiyyk/?utm_source=reddit&utm_medium=web2x&context=3

0

I will tell you how I solved my issue. I royalty messed up my system after a script got hung for a changing of my username for the main admin account in multiple files. This locked me out unable to met correct login credentials. I "force-moved" all the root files of the last update recover before the issues E.G.: mv -f /run/timeshift/backup/timeshift/snapshots/2023-05-13_17-55-48/* /

Right after this I logged out and logged back in. Did restart. Upon the new logon after booting, once this happens.

Now before doing this i kept reaching the "Unable to mount devices".

But after this little trick. Open TimeShift, Click the very first (earliest dated) boot to recover... If this does not work, close TimeShift and repeat for the next.

Eventually the files will match close enough to the files you already forced to your root and will back you up to a new restore..

This was a do or die situation for me because I spent 3 hours setting up my Fedora Server, before I broke the system. Luckily, placed a TimeShift backup before setting up the server. May of lost my 3 hours of work, but recovered 3 months of time and files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .