1

Every time I start gdb, the following information is displayed:

GNU gdb (Ubuntu 9.2-0ubuntu1~20.04.1) 9.2
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
--Type <RET> for more, q to quit, c to continue without paging--
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word".

I have to enter Enter to proceed. This prevents me from automating gdb script execution. Is there a way to skip the help information?

1 Answer 1

1

Yes, add the --silent option (aka -q, -quiet, --quiet, -silent and abbreviations thereof):

$ gdb --silent
>>>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .