1

I have dual booted my computer with Fedora 36 and Windows. I wanted to change the boot order on my computer and so I installed GRUB customizer on Fedora. GRUB Customizer did not show all of my OSs, as could be seen in GRUB. Rather only showed Windows and BIOS (UEFI Firmware Settings), I had accidentally saved the settings on GRUB Customizer, and now when I turn on my computer I am only given the option of accessing Windows or BIOS, and I cannot seem to find a way to edit GRUB from Windows nor access Fedora. How can I solve this to access Fedora?

When I go into the BIOS, my Fedora installation is still present in the boot order. Only on GRUB can I not find it.

Pastebin from boot repair: https://paste.ubuntu.com/p/H7xbk7WGzX/

Partitions as shown by GParted

9
  • The pastebin says "You need to be logged in to view this paste."
    – telcoM
    Commented Jul 11, 2022 at 14:04
  • Yeah unfortunately you need to make an account with them if you want to view the paste, I had to do that too Commented Jul 11, 2022 at 14:36
  • Grub customizer replaces the grub script files with its own proxy files. You need to totally reinstall grub to restore grub's files. You can manually boot from grub, use chroot to reinstall grub from chroot, or use Boot-Repair to reinstall grub or Supergrub to boot. to manually boot you have to get to grub's terminal & manually type in boot stanza. askubuntu.com/questions/53578/… & help.ubuntu.com/community/Boot-Repair & supergrubdisk.org/rescatux
    – oldfred
    Commented Jul 11, 2022 at 15:26
  • Boot off of a Fedora ISO written to a USB stick, and you should be able to boot a live OS. From there you can rescue your grub configuration. Grub customizer doesn’t understand the bootloader spec grub settings in Fedora and really should be removed from Fedora since it is so broken.
    – jsbillings
    Commented Jul 11, 2022 at 17:52
  • @oldfred I have tried using Boot-repair, however I do not receive the "Recommended pair" option, I have now just tried Supergrub from a USB however I do not receive the option to install grub onto my hard drive, only on the USB. This leads me to think I'd have to install Supergrub onto my actual hard drive for it to work. Which I'd prefer to avoid but if I have to then I will. Commented Jul 12, 2022 at 12:55

1 Answer 1

0

I believe I found a solution that would not require reinstalling, though I am not entirely sure as I do not have this problem anymore. When using commands such as sudo grub2-mkconfig -o /boot/grub2/grub.cfg. It would find Windows Boot Manager and UEFI Firmware settings. Leading me to believe that this is not an issue with GRUB Customizer.

I was trying to install a grub theme and at first it was not working, until I found this https://github.com/VandalByte/grub-tweaks#-fix-for-grub-theme-not-showing-up--fedora-ubuntu-. After changing /etc/default/grub. Running grub2-mkconfig again would show all linux distributions that I normally saw on GRUB. Leading me to believe that if I had not reinstalled fedora, this would be my solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .