13

Short Question

Is there a way to adjust the mouse wheel scroll sensitivity in Fedora 18?

Long Question

I'm running Fedora 18, with the standard Gnome desktop. I use a Logitech M705 mouse with the free-scrolling mouse wheel, which I love. In windows, I'm able to configure how many lines to scroll per notch of the mouse wheel. In Fedora, though, there doesn't appear to be any analogous configuration option. The default is quite sensitive for this this mouse, scrolling approximately 3 lines per notch. Since the wheel is free-spinning, even small motions trigger several notches, making it hard to use in Fedora. Is there a way for me to reduce the sensitivity of the mouse wheel?

Windows Mouse Configuration Windows Mouse Configurtion

Fedora Mouse Configuration Fedora Mouse Configuration

4 Answers 4

9

This answer is specific to Logitech devices with Unifying receiver, but you're mentioning one explicitely in your question.

Install solaar, a tool which can be used to pair devices with the unifying receiver, but also provides basic device configuration (and status information like battery level). Select the mouse, disable "Smooth Scrolling".

3
  • I have an ordinary m325, and solaar says read/write operation failed next to the smooth scrolling option.
    – Jerther
    Jan 30, 2017 at 13:52
  • I'm sorry I cannot really help you with this. Make sure to run the newest solaar release (it is not packaged for all distributions in a recent version) and try running solaar from the command line, maybe you get additional information on what's going wrong in a terminal window.
    – Jens Erat
    Jan 31, 2017 at 20:24
  • 1
    Running through terminal did not yield anything useful, and I'm running the latest version 0.9.2. Although, I found this page which seems to list my "ordinary" m325 as not supported. Oh well. I guess I'll talk to the dev there. pwr.github.io/Solaar/devices.html
    – Jerther
    Jan 31, 2017 at 20:58
2

A solution can be edit or create xorg.conf in /etc/X11 with this lines

Section "InputClass"

Identifier "Wheel Emulation"
MatchIsPointer "on"
MatchProduct "TrackPoint"
Option "EmulateWheelButton" "2"
Option "EmulateWheel" "on"
EndSection

save and restart X

references http://fedoraproject.org/wiki/Input_device_configuration#Example:_Wheel_Emulation_.28for_a_Trackpoint.29

2
  • 2
    I tried this, but it had no noticeable effect. Clicking through to your source link and reading the description doesn't inspire me to anticipate any change in wheel behavior; this is a method for holding a button and then approximating a mouse wheel with a trackpoint. I don't need to emulate a wheel, because I already have one! Thanks for your suggestion, though. I wish the results were better. Apr 5, 2013 at 21:57
  • That is because this only turns the middle button on the trackpad into a scroll wheel. It does not effect the mouse scroll wheel. Nov 11, 2015 at 17:02
2

I just gave IMWheel a try and it worked for me (Ubuntu distro – not Fedora, but the instructions work for any distro).

Install according to the distro you use (rpm -i imwheel for Fedora), edit the file ~/.imwheelrc and paste the following lines to it:

".*"
None,      Up,   Button4, 3
None,      Down, Button5, 3
Control_L, Up,   Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L,   Up,   Shift_L|Button4
Shift_L,   Down, Shift_L|Button5

Run imwheel --kill and voilà, you're running!

The value 3 at the end of the lines that start with None is the number of lines to scroll. Play with these values to obtain the sensitivity that is the best fit for you. Complete and detailed instructions can be found at How To Change The Mouse Scroll Wheel Speed In Linux Using imwheel at Web Upd8.

1

I wrestled with this apparent bug too. If you dual boot with Windows, and use a Microsoft wireless mouse, and have a motherboard that is always powered you get the problem in Linux. Briefly, Windows messes with the mouse transceiver configuration so Linux sees the wheel as scrolling way too fast, which it is after running Windows. The workaround is to unplug and replug the mouse USB transceiver. Unplugging resets the transceiver and makes it work properly in Linux.

The general fix is to install resetmsmice. Since it's a Microsoft hardware-software issue, I would not count on a general Linux modification to fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.