0

I am trying to install zabbix-agent on openSUSE 42.3 but it gives me the following error view atached image of the error

Repository 'openSUSE-Leap-42.3-Apache' is invalid. [openSUSE-Leap-42.3-Apache|http://download.opensuse.org/repositories/Apache/openSUSE_Leap_42.3/] Valid metadata not found at specified URL Please check if the URIs defined for this repository are pointing to a valid repository. Warning: Skipping repository 'openSUSE-Leap-42.3-Apache' because of the above error. File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.3/'

An idea how to solve this error?

1
  • Please don't post images of text. Copy and paste the text itself into your question and format it as code by selecting it and pressing Ctrl-K or by using the editor's {} icon.
    – cas
    Jun 29, 2022 at 2:48

1 Answer 1

0

Do not post images where plain text will do.

42.3 reached end of life 3 years ago, and the files appear now to have been removed from the opensuse website.

You need up upgrade.

Due to how old that release is, you will not be able to upgrade directly to 15.4 which is the latest. You will be better to install from scratch.

2
  • Any other method how to install it skipping these files? I really have to install it and i cant upgrade the server right now.
    – Eljano95
    Jun 28, 2022 at 17:48
  • Then I suggest you download the source software and build/install it yourself, but then again, you'll probably run into dependency hell. You really should have updated a while ago.
    – Bib
    Jun 28, 2022 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .