0

I used to dual boot Windows and Fedora 35, and decided to just run windows in a vm. I deleted the Windows partitions successfully, but now I have free space in the middle that I can't figure out how to move safely.

Since I don't have a swap partition, this question doesn't help, and since the partitions are on the same disk, I can't use this question.

I don't want to use GParted because it's not installed on my Fedora live usb (and other unrelated reasons), so my options are Gnome Disks and blivet-gui. Is there a way to safely move the free space from the middle of nowhere to my main partition?

Print lsblk

Return mountpoint for fedora_localhost-live (nvme0n1p6).

$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
zram0       252:0    0     8G  0 disk [SWAP]
nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   100M  0 part /boot/efi
├─nvme0n1p5 259:2    0     1G  0 part /boot
└─nvme0n1p6 259:3    0 350.9G  0 part /home
                                      /

blivet-gui screenshot

Many thanks!!

1 Answer 1

0

You can't "move" free space. It also doesn't solve anything! You'd still need to tell your / filesystem to use that.

However, your filesystem that you want to extend is btrfs - perfect! You can just add more partitions to the btrfs volume to extend its size, no need to move anything. And since this is an ssd and not a spinning disk, this also has no performance downside at all.

It's quite doable:

  1. Use blivet-gui to add a new partition that uses up your free space. Don't format it!
  2. Note down the name of that position, e.g., nvme0n1p42.
  3. Add the new space to your existing volume: sudo btrfs device add /dev/nvme0n1p42 /

That's it! You can use the new space right away.

8
  • Thank you!! Simple enough, however it threw an error: / is not a btrfs.... I tried using the path for the Fedora partition, but of course that didn't work. Could it be because my /boots are efi and ext4? That leads to another question, but I'm not sure if I should start a new post. I (probably) don't need 2 /boots, so how do I know which one to remove?
    – Keiva
    Jun 30, 2022 at 19:12
  • you need both partitions, one is the EFI boot partition, the other is for your second stage bootloader. Also, note how small they are; what do you care about a single GB? Your screenshot certainly looks like your fedora_localhost-live partition is btrfs, according to the table at the bottom! So, you need to replace what I presumed to be its mountpoint, /, by where it's actually mounted. Jun 30, 2022 at 19:42
  • Not worried about the 1 gig, I just like to keep things clean. I ran lsblk to find the mountpoint, and it's /home, but changing that in device add threw the same error. I'll add the log of lsblk to the question.
    – Keiva
    Jun 30, 2022 at 23:16
  • Lsblk might not be the tool of choice to figure out which filesystem type is mounted where. mount would be! Jul 1, 2022 at 1:24
  • I tried using findmnt, /proc/mounts and df. Only lsblk returned anything. The other 3 didn't return anything at all.
    – Keiva
    Jul 1, 2022 at 2:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .