2

So I recently got an Alienware desktop computer because there was a big sale on it, and then I instantly installed Linux on it after doing a bios update. Everything works great apart from one thing, I can only shut the computer off with the power button or else it will quickly turn right back on after running sudo shutdown -h now or even just using the shut-down button in the DE. It is different from a reboot since the computer makes a clicking sound that it usually does when shutting down, which is then followed by another click that turns it back on, as if I have pressed the power button, and the OS boots as normal.

I have tried turning off Wake on Lan in the bios, Allow USB devices to wake device, and any other options related to automatically waking the device. The problem is still there and will not go away. This happened both on openSUSE Tumbleweed, and Arch. I then installed Windows back to see if maybe it's just a hardware issue and as expected, the computer stays off when pressing "shut down" in Windows.

Is there any way to tell what is causing this shutdown or other possible solutions to this issue?

EDIT: My computer is using an AMD Ryzen 5900X, the model number of the device is AWAUR10-A815BLK.

1
  • Welcome to the site. It seems you are working from two accounts. Please see the help center topic on how to merge them.
    – AdminBee
    Jun 27, 2022 at 9:48

1 Answer 1

2

Without knowing the exact model of the system or even the chipset used in it, this will be a shot in the dark... (Please edit your question to add this information if possible.)

Some versions of the Intel XHCI USB3 controller effectively require their driver to be loaded when the system is shutting down, as the controller will immediately wake up the system again (exactly like you described) if it has not had the proper USB controller shut-down steps executed by the driver. Just leaving such a controller alone to mind its own business at system shutdown time is not an option with those controller versions.

I think this bug appeared with the Lynx Point and Panther Point chipsets, if I recall correctly.

You might also run acpitool -w as root, note the PCI IDs of the devices that are listed as wake-up enabled, check the lspci output to identify them, and use the numbers from the acpitool -w with acpitool -W <number> to try and disable the wake-up capability from some or all wake-enabled devices, and see if it helps.

If you find it stops the wake-ups, you will probably need to add a script to be executed as part of the system shutdown process, which will run the required acpitool command(s) just before shutdown.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .