1

I've been having troubles with installing the tidyverse package in Rstudio and more recently when reinstalling R. I'll post my most recent error message when reinstalling R below after system info.

My system info to start: Lenovo Thinkpad T14s Gen 2a OS:Dual boot with Linux Mint Cinnamon 20.3 (una)(kernel 5.13.0-51-generic), and Windows 10 on separate partition.

userXXXX:~$ sudo apt install --no-install-recommends r-cran-tidyverse Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help resolve the situation:

The following packages have unmet dependencies: r-cran-tidyverse : Depends: r-cran-broom but it is not going to be installed Depends: r-cran-dbplyr but it is not going to be installed Depends: r-cran-dplyr but it is not going to be installed Depends: r-cran-dtplyr but it is not going to be installed Depends: r-cran-forcats but it is not going to be installed Depends: r-cran-googledrive but it is not going to be installed Depends: r-cran-googlesheets4 but it is not going to be installed Depends: r-cran-ggplot2 but it is not going to be installed Depends: r-cran-haven but it is not going to be installed Depends: r-cran-hms but it is not going to be installed Depends: r-cran-httr but it is not going to be installed Depends: r-cran-modelr but it is not going to be installed Depends: r-cran-readr but it is not going to be installed Depends: r-cran-readxl but it is not going to be installed Depends: r-cran-reprex but it is not going to be installed Depends: r-cran-rvest but it is not going to be installed Depends: r-cran-stringr but it is not going to be installed Depends: r-cran-tibble but it is not going to be installed Depends: r-cran-tidyr but it is not going to be installed E: Unable to correct problems, you have held broken packages.

It seems like I need to remove these broken packages before reinstalling the new ones. If there is anyone that can help with going about this it would be greatly appreciated! Thank you!

New contributor
notsotidyverse is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

0

Your Answer

notsotidyverse is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.