This is the first time in my life I use Linux and it came with Fedora 35. After the laptop updated to Fedora 36, audio stopped working and I really have no idea what to do to fix it, as I mention I'm not very familiar with the OS, but I've tried some things I saw online and it seems I have the "no soundcard" problem, but I may be wrong... PLEASE HELP!

2 Answers 2


Things you can try (I'm not sure these programs are installed in Fedora):

  • Run pavucontrol and check that neither your output devices nor the application that's supposed to play audio are muted

  • Run alsamixer in a terminal, and press 'm' to unmute master and pcm channels (use F6 to select the right card)

  • Run pactl info in a terminal to verify that the 'Default Sink' points to the correct device. If that doesn't seem to be the case, you can list the available devices with pactl list sinks and set the default sink with pactl set-default-sink <name-of-device>

  • There are some Reddit threads*, where multiple people report that replacing wireplumber with pipewire-media-session by dnf swap wireplumber pipewire-media-session, and (re-)starting the pipewire-media-session service with systemctl --user restart pipewire-media-session fixed the issue for them.

* https://teddit.net/r/Fedora/comments/qmtl59/no_sound_audio_after_upgrade_to_fedora_35/

* https://teddit.net/r/Fedora/comments/q57gkk/no_audio_device_after_upgrading_to_fedora_35/

  • Hi, thanks! I just tried it, I do not have pavucontrol but it asked me if I want to install it so I selected yes... I do have the alsamixer, the master is not muted and when I press F6, the options are -Default or enter device name
    – Ana Vera
    Jun 21, 2022 at 16:03
  • I just installed PulseAudio and it says No cards available for configuration =(
    – Ana Vera
    Jun 21, 2022 at 16:05
  • "I just installed PulseAudio" - I'm not sure that was a good idea since I just read that Fedora uses pipewire by default (pavucontrol and pactl work with both pulseaudio and pipewire).
    – anick
    Jun 21, 2022 at 16:11
  • Not sure, if this helps, but seems to be a similar issue: unix.stackexchange.com/questions/703927/…
    – anick
    Jun 21, 2022 at 16:38
  • 1
    Just tried that, but when I open the control, everything seems alright. In 'Configuration' Tab it says Celeron/Pentium Silver Processor High Definition Audio and it is not Off, it's in Stereo Output. When I try to change it to any other option I can hear something like a brief click but that's it. I tried playing something but still no sound, and while testing everything I can see in the 'Output Devices' nothing is muted but still the bar moves detecting what I'm playing...
    – Ana Vera
    Jun 29, 2022 at 15:57

I just installed Fedora 36 for the first time and had the same issue. I found a YouTube video that says how to fix it:


Start at around time 4:30 (you'll need to enable the RPM Fusion repository that he talks about at this point - the next part he talks about the sound not working and what to do)

***I did not actually try this because I switched desktop environments and the sound started working again...

  • 1
    Hi there! Thanks a lot! I tried what the video says but still no results. However, I learned new stuff with the video, thank you! Just out of curiosity, what did you do that fixed the audio? What do you mean with "switched environments"? Sorry, I'm new with this lol
    – Ana Vera
    Aug 9, 2022 at 19:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .