0

Update:
Besides uname -a, I also tried the following methods to get the distro info.

[root@HTNICE usr]# lsb_release -d
-sh: lsb_release: not found
[root@HTNICE usr]# cat /etc/*-release
cat: can't open '/etc/*-release': No such file or directory

Original question:
I'm working on an embedded board. According to the few-page-only manual, it comes with Ubuntu 12.04 yet I found the kernel not that old.
enter image description here

The problem is: I'm unable to install anything I want. When I tried apt, it said "command not found". Downloaded the .deb file and then using dpkg, it said there is no status file. The /var/lib/ directory doesn't even exist.
enter image description here

Most of the system commands I find common in other Linux distributions point to busybox, including the dpkg I intended to use to install apt.
enter image description here

Is there any way to bring the apt back so I can start install the packages I need for my work? Thanks.

3
  • 1
    Don't post images, and try creating the directory /var/lib/dpkg and retry.
    – Bib
    Jun 21 at 8:18
  • 2
    The error message shows that your busybox has indeed (rudimentary) dpkg function included. The problem seems to be that the package system is not initialized which will probably lead to a mess of unresolved dependencies.
    – Philippos
    Jun 21 at 8:47
  • 1
    You need neither apt, nor dpkg to install packages - deb packages can be simply unpacked and installed directly. Considering you have no DPKG database using APT is simply redundant - it will whine about missing dependencies. Jun 21 at 11:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.