0

The reason I’m trying to do this is I like the default font called “fixed” on the console, but it’s too small.

the only way I’ve found to make the font bigger is to use “terminus”, but that font is so ugly!

I found out how to change fonts here: /etc/default/console-setup

And then when I edit it I get:

CHARMAP="UTF-8"

CODESET="Lat7"

FONTFACE="Fixed"

FONTSIZE="28x14"`

When I manually made the font bigger by making it “fixed” and “28x14”, it makes the font size bigger, but automatically switches the font to terminus.

I want to change the font face to Adobe Source Code pro semi-bold.

I downloaded the font following these instructions: https://askubuntu.com/questions/193072/how-to-use-the-adobe-source-code-pro-font

I then ran this to see if it was downloaded: la /use/share/consolefonts/ | less

I didn’t see the newly downloaded font in there, and now I’m not sure what to do next to change the default console font.

Edit: I’d like to do it without fbterm, and without framebuffer (I also don’t really know what it means, but apparently it affects performance?)

3
  • 1
    You can't use truetype or opentype fonts on the console without converting them first to a bitmap psf or psf.gz format first (see e.g. here), and the results are seldom what you'd hope for. But once done you can probably just use sudo setfont.
    – frabjous
    Jun 20 at 1:50
  • What frabjous wrote. There are nevertheless several other possible choices than those linux distros default on installing, if one of those listed (and pictured) there : alexandre.deverteuil.net/docs/archlinux-consolefonts suits you better, you can download and install it. (even under a non ArchLinux distro)
    – MC68020
    Jun 20 at 6:50
  • Since the question is tagged "x11" and "terminal", I assume it is not actually about the console (ie. tty) but about the terminal emulator (xterm, urxvt, st, gnome-terminal...). Setting the font there depends on the terminal emulator being used. Jun 23 at 4:58

1 Answer 1

-1

According to the console-setup man page, you can't do what you're wanting to do:

Valid font faces are: VGA (sizes 8x8, 8x14, 8x16, 16x28 and
16x32), Terminus (sizes 6x12, 8x14, 8x16, 10x20, 12x24, 14x28 and
16x32), TerminusBold (sizes 8x14, 8x16, 10x20, 12x24, 14x28 and
16x32), TerminusBoldVGA (sizes 8x14 and 8x16), and Fixed (sizes
8x13, 8x14, 8x15, 8x16 and 8x18). If however CODESET=Ethiopian,
then the available font faces are Goha and GohaClassic, each in
sizes 8x12, 8x14 and 8x16.

I'm wondering what problem you're actually trying to solve here. What are you doing when you're experiencing the font size as too small?

4
  • Eye strain, I want to sit further from my monitor and be able to read perfectly. I also like the sharpness of the default font. I want it to stay big even when I reset my computer Jun 20 at 2:50
  • Am I to understand that you're talking about when you're working at the command line?
    – MDeBusk
    Jun 20 at 6:46
  • 1
    @MDeBusk “you can’t do what you’re wanting to do” — not quite, see the FONT directive further down the man page (or in /etc/default/console-setup). Jun 20 at 9:41
  • @StephenKitt That'll teach me to keep reading. Who says man pages have to be coherent? :D
    – MDeBusk
    Jun 20 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.