2

I'm trying to find out why the performance of a newer and faster computer (NUC11) is so much worse than an older (NUC6). I would expect the NUC11 to blow the older system out of the water, but quite the opposite is the case.

With performance I mean the "subjective Gnome responsiveness", which I could luckily quantify by running the glmark2 benchmark which shows that the old NUC6's score is orders of magnitude higher (2901) than the NUC11's (187). I don't know if that's a good methodology to quantify the perceived system responsiveness (speed of windows opening, hot corner, scrolling lag, etc), but let's assume for a moment it is (happy to run other benchmarks).

Here are some facts about the systems. I tried to make them as equal as possible for comparison. Both run Fedora 36, latest Gnome 42/Wayland, I ran the benchmark under same kernels (5.17.14-300.fc36.x86_64), the driver they are using is the Intel i915 (same version as far I can tell via modinfo i915)

NUC6

  • CPU: i7-6770HQ (Q1'2016), built-in: Intel Iris Pro Graphics 580
  • 32GB RAM (speed 2133 MT/s)

NUC11

  • CPU: i7-1165G7 (Q3'20), built-in: Intel Iris Xe Graphics + Discrete Geforce RTX 2060 (Nouveau nv166 driver)
  • 16GB RAM (speed 3200 MT/s)

Granted, the NUC11 has half the RAM (but it's never fully allocated during the benchmark or when I run Gnome), but that's all I can see where the NUC6 has a leg up. In every other aspect, the NUC11 should by far outperform the NUC6, in particular since it has a discrete GPU to help rendering the Gnome desktop (I don't know if that's how Wayland works, but I would think so). I can't turn off the discrete GPU unfortunately to make the systems more alike (to eliminate any possible conflict between the two GPUs). As a side note, the NVidia scores ~800 glmark2 points which also doesn't sound plausible when comparing it with the 6 year old NUC6's internal GPU which scored 2901.

Something is slamming the brakes in the NUC11, but so far, I couldn't find anything. Is there anything else anyone can think of that I could try to troubleshoot why the NUC11 is so much slower than the much older NUC6? Any help, pointer is appreciated.

4
  • 3
    Maybe try Xorg for a change? I know people are obsessed with Wayland but it's still not ready IMO specially not with NVIDIA. docs.fedoraproject.org/en-US/quick-docs/_images/… Also make sure NVIDIA drivers are properly installed. Here's a specific Linux NVIDIA forum for such questions: forums.developer.nvidia.com/c/gpu-graphics/linux/148 Jun 18, 2022 at 15:22
  • 1
    For Xorg, the benchmark scores about the same (184) for the integrated Intel GPU and the RTX score actually went down (589). I'm going to try out with the official proprietary drivers...
    – orange
    Jun 18, 2022 at 22:35
  • Installing the 515.48.07 Nvidia driver and removing the nouveau drivers brought a score of 11123 which is a noticeable improvement in terms of responsiveness.
    – orange
    Jun 19, 2022 at 0:59
  • However there are a few odd things now. (1) I don't have a Wayland option in GDM any more, the score is Xorg (I might have removed that when uninstalling a previously failed Nvidia driver before trying it again now). (2) GDM boots up in some weird colours (I would say 8 bit colour depth, but it changes every time - hardly readable font) - I "fix" this by hot-plugging another monitor (ALT+F2 r doesn't restore normal colours) and I have now "NVIDIA GeForce RTX™ 2060 / NVIDIA GeForce RTX™ 2060" showing (twice) in my GNOME settings/about screen where there was the Intel GPU mentioned before.
    – orange
    Jun 19, 2022 at 1:00

0

You must log in to answer this question.

Browse other questions tagged .