2

Name says it all, I have a Dell Inspiron 15 3525 that cannot resume from sleep in Linux whether caused by invoking systemctl suspend or by closing/opening the lid. There are many problems similar to mine, however none of the solutions I have found do function. For example most are fixed with nvidia drivers (no nvidia here) or by enabling lid in acpi (no lid listed as shown below). Does anyone have advice without digging into DSDT modifications? My attempts at that result in hundreds of errors that I lack the knowledge to fix.

Here is my neofetch information:

OS: Arch Linux x86_64 
Host: Inspiron 15 3525 1.3.0 
Kernel: 5.18.3-zen1-1-zen 
Uptime: 13 mins 
Packages: 1061 (pacman), 7 (flatpak) 
Shell: zsh 5.9 
Resolution: 1920x1080 
DE: GNOME 42.2 
WM: Mutter 
WM Theme: Adwaita 
Theme: Adwaita [GTK2/3] 
Icons: Adwaita [GTK2/3] 
Terminal: gnome-terminal 
CPU: AMD Ryzen 5 5625U with Radeon Graphics (12) @ 2.300GHz 
GPU: AMD ATI 03:00.0 Barcelo 
Memory: 1895MiB / 7289MiB 

Here is my /proc/acpi/wakeup:

❯ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
GPP0      S4    *disabled
GPP1      S4    *enabled   pci:0000:00:01.2
GP17      S4    *enabled   pci:0000:00:08.1

Interestingly, LID is not shown as a device. That being said, when I close the lid the laptop will sleep.

Unsure if it's relevant but I am running secure boot in order to power on my annoying windows 11 encrypted drive. I turned off mok verification so I always get a small booting in insecure mode during power on.

Thanks in advance!

EDIT: free -m output:

❯ free -m
               total        used        free      shared  buff/cache   available
Mem:            7289        1605        4771          48         912        5393
Swap:           8191           0        8191

2
  • You need at least as much swap as you have RAM to be able to hibernate. The terminal commands free , man pm-is-supported mkswap swapon will help.
    – waltinator
    Jun 17, 2022 at 23:51
  • @waltinator, thanks for the response but I added my free -m output and my swap file exceeds my ram size EDIT as I type this I thought of something I should try in regards to the hibernate function, I believe archwiki had something about kernel flags for swapfiles...
    – Viscorbus
    Jun 18, 2022 at 18:29

2 Answers 2

3

Turns out for my particular use case, the solution is to forgo sleep entirely as I think Dell ACPI just does not like Linux. Properly implementing hibernate worked. Thanks to waltinator for sparking my memory!

Here are my steps (All stolen from ArchWiki hibernate of course):

  1. identify and setup kernel parameters resume=UUID=... and resume_offset=...
  2. add resume HOOK to /etc/mkinitcpio.conf
  3. modify /etc/systemd/sleep.conf to prevent suspend and allow hibernation
  4. modify /etc/systemd/logind.conf to make the lid cause a hibernation event
  5. add /etc/sysctl.d/99-swappiness.conf to reduce system swappiness to 10
  6. enjoy
0

Install Tweaks, and slide the suspend off.  See Why does my computer turn off when I close the lid? for details.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .