1

I want to install the GVST plugin pack so that Audacity (from Flatpak) can see it. I am using KDE Neon (fairly new, I'm not sure how to find the version number). I've tried various directories to copy the .so plugins to, but so far no success. I have restarted Audacity each try to make sure it refreshed everything.

If possible, I'd like other VST supporting Flatpak apps to see the plugins also.

2
  • Where did you get your .so from ? How did you install you Audacity (for your user only / system-wide) ?
    – MC68020
    Jun 16, 2022 at 7:19
  • @MC68020 I downloaded an archive from the GVST website for 64-bit Linux systems, which is what I have. I ran “flatpak install audacity”.
    – TheLabCat
    Jun 16, 2022 at 12:49

1 Answer 1

0

Audacity is said capable of searching for vsts in all the directories specified in the VST_PATH environment variable.
So set (or update) this variable including the directory in which you downloaded your pack. This is not needed if you installed in /usr/lib/vst /usr/local/lib/vst or ~/.vst standard locations.

Of course, you will need to explicitly enable each one of them them in Audacity using the Effect > Add / Remove Plug-ins... menu item.

BTW, you are aware that audacity does not support VSTi, VST3 and real-time VST effects (that change the audio data while it is being written). So all what you downloaded might not be Audacity friendly.

5
  • VST_PATH defaults to blank. I added ~/.vst to it, and dropped the plug-ins there, but to no effect. Would such an operation usually require a system reboot?
    – TheLabCat
    Jun 16, 2022 at 13:22
  • @TheLabCat Not at all. Only, at most logout/login and of course restart Audacity. BTW, you should not have needed to add your .vst home subdir since it is supposed in the standard locations.
    – MC68020
    Jun 16, 2022 at 13:35
  • Well, the folder ~/.vst didn’t exist at all to start with. Is Audacity supposed to create it? If so, the fact that it’s a Flatpak probably changes where it is.
    – TheLabCat
    Jun 16, 2022 at 13:38
  • @TheLabCat : Hence my very first question you did not answer : Did you install audacity for your own user or system-wide ?
    – MC68020
    Jun 16, 2022 at 13:54
  • I don’t know. I just used the default settings without running flatpak with sudo.
    – TheLabCat
    Jun 16, 2022 at 14:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .