5

I am trying to install OpenBSD on HP Chromebook 11 G4 with CoreBoot (UEFI) installed through MrChromeBox firmware-util script.

During the initial boot prompt (when you see the boot>) I can easily type anything there (like entering into User Kernel Config with boot -c for example).

But after loading the installation program each time I press any key, and I mean literally any key including power button or enter, I need to wait for 1-2 seconds before chromebook responds. What is even worse is that each key-press is recorded/recognized multiple times.

I have already found that setting kern.timecounter.hardware=acpihpet0 using sysctl can help but unfortunately I can't get past installation (typing "done" is not an option and it is required in some places because of failed load of initial iwm0 firmware)

I know it might be the tip of an iceberg but I would like to begin with fixing the key-presses issue during an installation process.

Since this suppose to be a question there should be at least one question mark. Is there any way to set kern.timecounter.hardware=acpihpet0 from UKC or any other way to fix each key being pressed multiple times during installation ?

As a side note: from I can see most things during boot are not configured (like acpicpu at acpi0 not configured or Intel Bay Trail LPC .... not configured.

Oh and I have already tried using an external keyboard with no luck since it does not work during installation program for some reason.

Update:

Just to preempt question since I did not mention this in the original question.

The installation program does not detect any disk except for the build-in emmc. If it was not for this I could simply install the OpenBSD with autoinstall (multiple "a" count as 1 in that particular prompt and naming the response file like "bbbbb" works).

Because of the above and the fact there is only wireless connection build-in I can't get sets necessary to finish the installation. I've managed to get past disk layout stage but there is nowhere I can get the sets from since the installation medium is also unavailable.

Update 2:

I have managed to install OpenBSD via Linux MX live usb with virtualbox installed.

Sadly the keyboard is still not working. Any external usb device is not recognized either.

When I press the power button I can see there is an info with something like:

pckbc timeout

I will keep this question updated.

1 Answer 1

5

You can try disabling acpihpet at the UKC:

UKC> disable acpihpet

It might be helpful to post a message to the misc@openbsd.org mailing list, so that the devs can help you out. If at all possible, include the full output of dmesg, but I understand it might be hard with a non-functioning keyboard. If you have another machine (with the same architecture, of course) around, you might try using that to install OpenBSD onto a USB stick and then use it to boot the Chromebook. That way you'd be booting a full kernel, which might correctly support the internal keyboard (and in all likelihood the external one too). It would then be easy to get the dmesg.

The way that the keyboard is attached might be relevant (old AT-style via pckbd, USB using uhid, I2C using ikbd, etc), and the full dmesg will also show/hint at why the USB keyboard isn't detected with the installation's kernel (which has support for a more limited set of hardware than the full one).

Update:

About the external drive: if you have to boot in UEFI mode on the Chromebook, then you'll need to make a UEFI installation on the external disk as well, instead of a Master Boot Record setup. To avoid reinstalling OpenBSD, see if you have something like a "legacy boot" option on the Chromebook's BIOS, and try to boot from the external disk. Otherwise, try to make an UEFI installation to the disk, using the spare machine.

2
  • thanks for the suggestions but unfortunately none of them solved the issue. I have tried disabling acpihpet but it did not do anything as far as I see. Installing OpenBSd on an external drive have not working because I get kernel panic with the message root device not found. I guess this might be because I am making the installation on a different (but similar) device. Anyway, thank you again for the suggestions.
    – zajer
    Jun 15 at 22:47
  • About the update: for this machine it makes no difference whether I use legacy seabios or UEFI. I have checked it multiple times. With seabios keyboard "repeats itself" just like in UEFI. And I have made sure the installation on an external disk was done in UEFI mode, still without luck.
    – zajer
    Jun 20 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.