3

Currently running KDE-Plasma-5.23.5 (X backend)/ KDE-Frameworks-5.90.0 / QT-5.15.3
I can assert that this used to work perfectly but am unfortunately unable to assert from which version of what the problem started to occur systematically.


Whatever the qt5 application I launch (kmail, kate, konsole, dolphin, qtdesigner…) I am no longer able to key in the â ä ë ê î ï ô ö ü û (as well as corresponding uppercase) characters. (usually possible via hitting the dedicated dead key then the desired vowel)

Keying any other directly accessible accentuated character works fine.

I suspect this problem to be restrained to qt5-ed apps since it does not impact non qt5-ed applications such as The-Gimp, Firefox, Chromium, Yoshimi (fltk), my Arduino prototyping platform, audacity… all launched from the same user under the same DE.


UPDATE 1 / XMODIFIERS :

Curiously enough, If I export XMODIFIERS= before launching my DE, or even within some konsole session, then, if I launch kate manually (via bash), the problem does not occur.
It however still occurs when starting kate from the KDE menu or clicking on its icon.
Therefore my problem would become, how should I set XMODIFIERS so that whatever qt5 app could automagically honour it ?
BTW, unless I export it explicitly, this variable is not part of the environment when my DE is running.

2 Answers 2

2

This is the solution I found (per pure chance). However it sounds so absurd to me that I cannot accept it as The answer.

Hence do not hesitate to post another answer suggesting another more logical way to proceed or explaining what is happening or if this is a deliberate will from devs. Whatever, I'll be more pleased awarding the bounty to anyone than having 50 Kudos lost for everybody.


Solution : Simply select the appropriate region in system settings / Regional Settings / Format (In this occurrence fr_FR)


Tl;Dr mostly rant :

A/ I had this previously set to "No change", assuming that implicitly meant "no change from active X settings when starting KDE." and since whatever X application started outside of KDE as well as whatever non-qt5 application launched from the desktop were just happy…

So : No change ? But from what actually ?

B/ Why does changes made for that setting only concern qt5 applications ?
Because they use some different input method ? As far as I can tell, since I don't use gnome, I build qtgui with support for only good old libinput and evdev. v.g without support for ibus. Not to say that the ibus-daemon is not running on my system.

C/ Why are the settings found under system settings / input devices / keyboard (Hardware, Layout, Advanced) no longer enough to ensure desired keyboard input behaviour ? (I am quite sure they used to be)

0

I had the same problem and I fixed it by changing my language in my System settings : Regional Settings/Region & Language/Language to American English (it should work with an another language. My old language seemed to be outdated).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .