1

I'm trying to change the default application for the filetype .xopp, which is a file for the xournalpp application. I currently ran the following commands:

xdg-mime query filetype 2022-06-09/note.xopp

which gave me: application/gzip. How can I make only the files that end in .xopp open in xournalpp? It works when I use a file browser, but when I run:

xdg-open 2022-06-09/note.xopp

it opens it in an unzipping program.

I'm currently using Manjaro Linux.

1 Answer 1

0

What worked for me on KDE (but on Ubuntu) was to open "File Associations" window from the application launcher (or alternatively open "System Settings" and go to "File Associations" there), then:

  • Create a new MIME type (the "+ Add..." button, bottom left)
  • Choose "application" in the menu and give "xopp" as type name

You should now find a new "xopp" entry under the "application" types; choose it and

  • In "Filename Patterns" click "+Add..." and input the "*.xopp" string
  • In "Application Preference Order" click "+Add..." and choose Xournal++ app.
  • You can also choose an icon by clicking on the white rectangle. Look for a xournal-related svg file in your system (in my case I chose /snap/xournalpp/current/usr/share/xournalpp/ui/pixmaps/application-x-xopp.svg)
  • Click "Apply" and "OK"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .