0

I have in my /etc/fstab

/dev/gpt/rootfs   /       ufs     rw      1       1

and gpart list shows a partition with the rootfs label:

3. Name: nvd0p3
   Mediasize: 16105245696 (15G)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 1024
   Mode: r1w1e1
   efimedia: HD(3,GPT,1d7be3e1-14fe-11eb-9c6b-0cc47ad8b808,0x6b2,0x1dff946)
   rawuuid: 1d7be3e1-14fe-11eb-9c6b-0cc47ad8b808
   rawtype: 516e7cb6-6ecf-11d6-8ff8-00022d09712b
   label: rootfs
   length: 16105245696
   offset: 877568
   type: freebsd-ufs
   index: 3
   end: 31457271
   start: 1714

yet, the system wouldn't boot any more. I fixed it by changing the /etc/fstab to

/dev/nvd0p3   /       ufs     rw      1       1

and it would boot. This is from where I am looking at this disk now:

# ls /dev/gpt
bootfs

also here:

# ls -l /dev/gptid
total 0
crw-r-----  1 root  operator  0x46 Jun  6 17:28 1d7be3d4-14fe-11eb-9c6b-0cc47ad8b808
crw-r-----  1 root  operator  0x5a Jun  6 17:28 1d7be3dc-14fe-11eb-9c6b-0cc47ad8b808

these two are nvd0p1 and p2, but p3 is missing.

It seems as though this gpart label is damaged.

Then I went ahead and made another one. I just copied the entire disk and set up the gpt all from scratch.

And lo and behold, once again the rootfs partition label is not showing up as /dev/gpt/rootfs.

But strangely, when I am attaching this disk to another running system, the /dev/gpt/rootfs shows up. Just not when this disk is used as the boot disk, then exactly the /dev/gpt/rootfs is missing. Everything else is there.

This is really bad. I have no idea what it can be, and by now run out of patience to try and fail other options.

Upon request, here is the contents of /boot/loader.conf:

debug.trace_on_panic=1
debug.debugger_on_panic=0
kern.panic_reboot_wait_time=0
autoboot_delay="-1"
beastie_disable="YES"
hint.atkbd.0.disabled=1
hint.atkbdc.0.disabled=1
boot_multicons="YES"
hw.broken_txfifo="1"
if_ena_load="YES"
console="comconsole"
2
  • 1
    Can you please edit your post to show the contents of /boot/loader.conf?
    – Jim L.
    Jun 6, 2022 at 19:49
  • @JimL. yes sir, done. Jun 7, 2022 at 4:48

1 Answer 1

0

Try adding these lines to your /boot/loader.conf:

kern.geom.label.disk_ident.enable=0
kern.geom.label.gptid.enable=0
kern.geom.label.gpt.enable=1
kern.geom.label.ufs.enable=1

Also, change your /etc/fstab line back to:

/dev/gpt/rootfs   /       ufs     rw      1       1

Give it a reboot, and comment below on your results. For bonus points, add these further entries to /boot/loader.conf, and edit your post to include any interesting output produced:

kern.geom.debugflags=7
kern.geom.label.debug=2

Good reading can be found here but it may only be edifying rather than directly solve your particular case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .