0

I'm having trouble with a VM I was using yesterday. After using, I closed the guest and updated my host machine (arch linux). Today I turned on the host and tried to turn on my guest and this message appeared:

Error starting domain: unsupported configuration: chardev 'spicevmc' not supported without spice graphics

Traceback (most recent call last):

File "/usr/share/virt-manager/virtManager/asyncjob.py", line 72, in cb_wrapper callback(asyncjob, *args, **kwargs)

File "/usr/share/virt-manager/virtManager/asyncjob.py", line 108, in tmpcb callback(*args, **kwargs)

File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 57, in newfn ret = fn(self, *args, **kwargs)

File "/usr/share/virt-manager/virtManager/object/domain.py", line 1384, in startup self._backend.create()

File "/usr/lib/python3.10/site-packages/libvirt.py", line 1352, in create raise libvirtError('virDomainCreate() failed') libvirt.libvirtError: unsupported configuration: chardev 'spicevmc' not supported without spice graphics

I'm using a dedicated nvidia card on a manjaro guest OS.

I'm not a linux expert.

Any idea what might be happening and how to fix this?

Any other info you need let me know.

UPDATE #1:

I removed the usb spice redirectors from my VM:

<redirdev bus="usb" type="spicevmc">
  <address type="usb" bus="0" port="4"/>
</redirdev>
<redirdev bus="usb" type="spicevmc">
  <address type="usb" bus="0" port="5"/>
</redirdev>

And now it works fine... I just can't have usb redirectors on the guest OS now... Anyone know why this is and how to fix it?

2
  • You should probably edit your question (and its title) to better reflect what you're now asking for help on. Commented Jun 6, 2022 at 17:36
  • Do the instructions at linux-kvm.org/page/SPICE (skip to "Enabling SPICE using virt-manager") help at all? I'm wondering if you've missed one of the settings Commented Jun 8, 2022 at 7:58

2 Answers 2

0

I had the same issue after updating my Arch host. In virt-manager I went to Display Spice and switched Type: VNC Server to Spice server and restarted the machine.

Everything worked fine after that.

The only issue is now I have to insert my ssh-key passphrase a thousand times before getting to the console viewer. I can live with that.

0

I had this issue also after I updated my arch linux, I then added the spice server because without the spice server I was unable to remove the two usb redirectors, I did that because I don't need them in my setup since I have a gpu passthrough vm and I use my secondary gpu for video output and I don't want to automatically redirect usb devices, read more here https://people.freedesktop.org/~teuf/spice-doc/html/ch02s06.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .