0

I'm getting the following error while trying to install pkg on FreeBSD 10.4-

Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest, please wait...
pkg: Error fetching http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest/Latest/pkg.txz: Not Found
A pre-built version of pkg could not be found for your system.
Consider changing PACKAGESITE or installing it from ports: 'ports-mgmt/pkg'.

When I try to install it using ports, I get the following error-

set: Illegal option -o pipefail
===> Options unchanged
set: Illegal option -o pipefail
*** Error code 2

Stop.
make[1]: stopped in /data/usr/ports/ports-mgmt/pkg
*** Error code 1

Stop.
make: stopped in /data/usr/ports/ports-mgmt/pkg

Is there any other way to install pkg or change default repo URL to download packages?

2 Answers 2

3

FreeBSD 10 has been out of support for four years, so there is no guarantee any packages are offered. Exactly what happens here: not even a package list is available anymore.

I can't really judge the ports errors, but unsupported is unsupported: I don't think this will take you anywhere. Pkg doesn't strike me as something you'd need to (or really, could) add from ports.

1

Newer ports tree will not work. You need a ports tree compatible with FreeBSD 10 to build your "pkg"

EOL was 5 Years ago, but you can still fetch and test it.

See: https://cgit.freebsd.org/ports/refs/tags

fetch https://cgit.freebsd.org/ports/snapshot/ports-10-eol.tar.gz

Beware of 5 years unpatched vulnerabilities.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .