35

After sysadmin replaced the NAS, I can no longer mount the network share with

sudo mount -t cifs //netgear.local/public /media/mountY -o uid=1000,iocharset=utf8,username="adam",password="password"

Both NAS are linux-based, one with Samba 3.5.15 (the old one) and the other with Samba 3.5.16 (the new one) (information obtained from smbclient)

I can, however, log in and use the share with the help of smbclient, like this:

smbclient  //NETGEARV2/public -U adam

What can I do? There is no smbmount on Linux Mint (nor on Ubuntu) anymore.

When I check dmesg I get this info:

CIFS VFS: Send error in QFSUnixInfo = -95
CIFS VFS: cifs_read_super: get root inode failed
  • In Ubuntu you have to install smbfs package. – Laurentiu Roescu Mar 28 '13 at 11:12
  • If the NAS are Linux based, do you need to access via CIFS? If they are exported with NFS as well, you should just use NFS instead. – Tim B Mar 28 '13 at 11:17
  • 2
    @LaurentiuRoescu as I said, there is no smbfs on recent Ubuntu. It says it is depreciated, and sudo apt-get install smbfs yelds E: Package 'smbfs' has no installation candidate. Package cifs-utils replace it, which boils down to mount -t cifs. – Adam Ryczkowski Mar 28 '13 at 12:44
  • 1
    Check dmesg, there should be further details about what went wrong from the kernel. – derobert Mar 28 '13 at 16:03
  • related question, in the context of ACL (cifsacl): unix.stackexchange.com/questions/403509/… – myrdd Jan 9 at 3:49
43

At work I encountered a similar problem. moun -t cifs just stopped working. Following mounting a CIFS/SMB resource and looking at the output of demsg, I found that adding the option vers=1.0 did the trick. My command looks like

mount -t cifs //server/folder ./mountpoint -o user=USER,domain=DOMAIN,vers=1.0

  • 10
    vers=2.0 can be a solution as well. – Karl Richter Feb 11 '18 at 22:53
  • 1
    vers=2.0 worked for me. No luck with sec=ntlm – Max Sep 10 '18 at 6:50
  • 2
    The root cause seems to shift over time: In 2013, most people needed sec=ntlm, then it was mostly a missing vers=1.0, now we see first occurrences of vers=2.0. :-) – Torsten Bronger Sep 21 '18 at 10:07
  • vers=3.0 worked for me. This could be a solution for someone else I hope. – Alex 12 hours ago
23

After seeing the dmseg and Googling, I found the solution:

One has to add the sec=ntlm option. The problem (feature?) is introduced in recent kernels (I use 3.8.4). I just didn't realize that the problem is kernel-related. So the correct way of mounting is:

sudo mount -t cifs //netgear.local/public /media/mountY -o uid=1000,iocharset=utf8,username="adam",password="password",sec=ntlm
  • b.t.w. - it also works if you add sec=ntlm using mount.cifs. ( sudo mount.cifs '\\server\share' '/mnt/share' -o domain=DOMAIN,username=USERNAME,sec=ntlm – epeleg Jan 19 '15 at 21:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.