0

EDIT solution: The problem was that I thought the package installs the driver but it was not the case (more about it in the accepted answer). When installing Nvidia driver I suggest going with .run file from archive here - if you need specific version, which was my case so I could not just autoinstall. The .deb package was not working for me.

EDIT2: I tried to install Cuda just now and failed. I've read there might be issues when using ".run" file, so I don't know if that is the way to go anymore.

I have Debian 10 (Buster) and I'm trying to install Nvidia driver 460.91. I downloaded it and tried to install as root by executing:

apt install ./<name>.deb

What I get is: https://i.imgur.com/FeErHh5.png

and the driver is not installed.

Why the Nvidia driver is not installed when it is claiming that the package is? Also the first run was extremely fast so it could not possibly install the driver.

I tried among other things running

sudo dpkg -i <name>.deb
sudo apt install -f

but got same result. For some reason it seems that the package is installed however the driver is not.

2
  • 1
    Welcome to Unix & Linux Stack Exchange! Please, don't post images of text
    – Kusalananda
    May 24 at 17:18
  • @Kusalananda Will avoid in the future. Seemed to me like a best way but now I realize it can be useful to copy it.
    – eXPRESS
    May 24 at 17:21

1 Answer 1

3

It’s not installing the package because the package is already installed:

nvidia-driver-local-repo-debian10-460.91.03 is already the newest version (1.0-1).

This package ships all the packages needed, but doesn’t install them; to do that, you need to run

sudo apt update
sudo apt install nvidia-driver
6
  • I don't understand, when I check if the driver is present (by executing nvidia-smi in terminal) it tells me "command not found" so I think the driver is not installed. EDIT: In the first run it was different but it definitely did not install the driver, it was like 0.5s.
    – eXPRESS
    May 24 at 16:30
  • I take it you think you’re installing the driver, but the package you’ve downloaded installs a repository containing the driver; it doesn’t install the driver itself. What instructions are you following? May 24 at 16:48
  • Thanks for the explanation. I did try to "apt update" but I get some error in it: i.imgur.com/VQ0lcNg.png
    – eXPRESS
    May 24 at 17:09
  • I tried to "apt remove nvidia..." so I can try to install the configuration package again but after it I still see "nvidia-driver..." in "dpkg --list". When I tried to "dpkg --remove nvidia..." it fails on dpkg: warning: 'ldconfig' not found in PATH or not executable dpkg: warning: 'start-stop-daemon' not found in PATH or not executable dpkg: error: 2 expected programs not found in PATH or not executable .
    – eXPRESS
    May 24 at 17:25
  • So after a while I decided to find a different way, found archive nvidia.com/en-us/drivers/unix/linux-amd64-display-archive with .run files (I understand similar to .exe on Win containing the instalation script), picked the one nvidia.com/Download/driverResults.aspx/177149/en-us I needed and the installation seemed to work, at least now i see report when i type "nvidia-smi".
    – eXPRESS
    May 24 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.