I have two user with these permissions (id)

uid=113(sonarr) gid=1001(sonarr) groups=1001(sonarr),1000(master),1002(qbtuser)
uid=1001(qbtuser) gid=1001(sonarr) groups=1001(sonarr),1000(master),1002(qbtuser)

I have a folder with these permissions.

drwxrwxr-x  6 master master  6 May 24 11:32 ./
drwxrwxr-x  5 master master  5 May  6  2021 ../
drwxrwxr-x 10 master master 10 Oct 20  2020 TV_Main

I've already rebooted the system. When I log in as qbtuser, I can touch a file or make changes with no issue. Obviously logging with master also has no issues.

But if I log in as sonarr, I get permission denied for the folder. But they have the same groups. What am I not understanding?


Edit for better clarification.

Yes, the entire tree has r-x permissions for ugo. I even tried changing the whole tree to g+rwx and still no luck.

It is a NFS share, version 4. The server has the same mappings for everything except uid 113. Maybe that's my problem? But I thought if the group was included it should work. I will explore this more.

To clarify permission denied, I can cd into the directories fine, or run ls fine. But if I try to touch file.txt or mkdir temp I get

mkdir: cannot create directory ‘temp’: Permission denied

If I make files w/ master/qbtuser, I can not edit, echo foo >> file, rename, delete or anything. Still the same Permission denied msg.

  • Do all the parent, grandparent, etc... directories all the way to the root directory have non-restrictive permissions for user sonarr (i.e. at least r-x for either group or others, as applicable)? Is this directory in a local filesystem or on a remote NFS or SMB share? If remote NFS, does the NFS server also have the same UID/GID mappings and group memberships, and which version of the NFS protocol is being used?
    – telcoM
    May 24, 2022 at 13:47
  • Please clarify what you mean by “I get permission denied for the folder.”  Can you cd into the directory?  Can you list it (e.g., with ls -la or echo *)?  If qbtuser or master creates a file, can sonarr modify the file (echo foo >> file), rename it or delete it? … … … … … … … … … … … … … … … … … … … … … … … … … Please do not respond in comments; edit your question to make it clearer and more complete. May 24, 2022 at 16:59
  • NFS 3 implementations often ignored membership of secondary/supplementary groups. I don't know about NFS 4 but it would be something to check. See (1) and (2). May 24, 2022 at 19:28


You must log in to answer this question.

Browse other questions tagged .