1

Good day!
Trying to install linux on new SSD but everytime, no matter what i do, even in LiveCD linux freezes and i have to restart PC from button.

Tried to install PopOS, Fedora and Debian. Also used Ubuntu livecd.
PopOS just freezes before installing
Fedora one tried to install, got bootloader error(i think because i used automatic disk partitioning and needed to make /boot/efi manually). But then LiveCD just freezed to death..
Debian installed successfully, but got kernel-panic when i tried to apt-get update && apt-get upgrade. Then freezed to death.
Ubuntu LiveCD worked well for little more time than others, but got death freeze when i tried to use GParted

So, the question is, does LiveCD has logs? How i can find a reason of this freeze?
Definately this is drivers problem.
Hardware:
Gigabyte B450 Gaming X
AMD 3500X
GeForce 1650
2 HDD(file storage NTFS), 2 SSD 2.5(one for windows NTFS and one for linux ext4+efi boot partition) and one M2(NTFS for games)

Linux freezes almost everytime i try to do disks operation(like partitioning). But i tried to do it only with SSD for linux(ext4)...
Only thing that i got in mind, is that i need to debug this debian kernel-panic, at least installed system has logs.

3
  • Try updating BIOS to the latest version and resetting BIOS settings. What's your GPU? If it's NVIDIA you could be using the nouveau driver which is quite finicky. May 21, 2022 at 12:30
  • Oh, sorry forgot to mention GPU. Geforce 1650. Also, without video drivers livecd works longer than with... May 21, 2022 at 12:34
  • Nope, bios update didn't helped. With nouveau:modeset=0 PopOS boots and still working around one minute. I just don't know what to do :c Already want to give up, any other thoughts? May 23, 2022 at 16:50

1 Answer 1

0

I think i found the problem. First i discovered, that PopOS runs smooth with only one RAM stick. 2 sticks on dual-channel or on single-channel - leads to crash.
So if you having such problem, try to look for X.M.P(extreme memory profile) in your BIOS
Another info that i found, but not tried - increase RAM voltages a bit, be careful it can damage your PC, read guides before doing that. Enabling XMP worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .