1

I installed a few plugins by adding lines to .tmux.conf

set -g @plugin 'noscript/tmux-mighty-scroll'

I installed with prefix I

I tried to scroll, and instead of doing its thing, it now ALWAYS says

Can't find pane: mouse

WORSE, I commented out the plugin line, and hit PREFIX alt u, to uninstall the plugins, and now tmux continues to give that same error.

I confirmed the plugin is gone from .tmux folder, and I can't see where else the memory of this plugin could be,

How do I get tmux to work the way it used to?

1 Answer 1

0

You're describing your config changes as not having an effect... and sourcing your .tmux.conf should do that but if it's not then you might need to close (kill, not detach) the sessions, and then start a new session with a new server using the updated config.

Regarding the error you're getting from that plugin... you may be able to solve that too... I'm not familiar with that particular plugin but there's a tmux config of set -g mouse on which may be relevant to that plugin's error.


edit: wait... you say:

PREFIX alt u

...which I assumed you had mapped to :source ~/.tmux.conf. Is that so? Try running that (via prefix+:) if you haven't.

2
  • Ah yes, I had to close ALL of the sessions - thanks.
    – user92979
    May 21, 2022 at 13:16
  • PREFIX alt u = uninstall missing plugins (tpm) I did have a set -g mouse on, commenting that out has stopped that error. Now I can't seem to scroll back into the console history - it scrolls the command history on the current line. Anyway that is another problem...
    – user92979
    May 21, 2022 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .