0

I'm trying to install rEFInd as my Arch Linux bootloader, but I can't get the boot manager to start.

I'm installing it from an Arch Linux live installation, booted from USB installation media. I've installed the refind package from pacman. I tried using the installer command refind-install --usedefault /dev/sdb2 --alldrivers, but that wasn't working, so I deleted everything and tried a manual installation.

Here's what my EFI directory looks like:

/boot/EFI/refind
            |___drivers_x64
            |    |___ext4_x64.efi
            |___refind.conf
            |___refind_x64.efi

Here's the output of efibootmgr:

BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0000,0004,0005,0006,0007
Boot0000* rEFInd Boot Manager
Boot0004* Windows Boot Manager
Boot0005* UEFI: Generic Flash Disk 8.07
Boot0006* UEFI: Generic Flash Disk 8.07, Partition 2
Boot0007* UEFI: Samsung SSD 860 EVO M.2 1TB, Partition 2

Relevant parts of efibootmgr -v (with Windows Boot Manager for comparison):

BootOrder: 0000,0004,0005,0006,0007
Boot0000* rEFInd Boot Manager    HD(2,GPT,[uuid],0x109000,0x200000)/File(\EFI\refind\refind_x64.efi)
Boot0004* Windows Boot Manager   HD(2,GPT,[uuid],0x109000,0x200000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.....

You can see that rEFInd Boot Manager has the highest priority in the BootOrder, but when I try to boot using that, it opens Dell SupportAssist, meaning it's not loading. Secure Boot is disabled.

I may have messed up my rEFInd configuration for Arch Linux, but the issue is that rEFInd isn't loading at all. Does anybody know what's wrong here?

1 Answer 1

0

Alright, I got it working. What I ended up doing was:

  1. Burn the rEFInd CD image to a USB drive (https://www.rodsbooks.com/refind/getting.html). While in arch-chroot, I used used wget and then the command dd if=image.iso of=/dev/sdd.

  2. Boot into that; it loaded fine

  3. Select the installation option from the rEFInd menu

And now it works! Still don't know why it wasn't working before, but the entries in efibootmgr -v are a little different (the working one has some stuff about PciRoot/Pci/Sata/HD instead of just HD).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .