0

I have tried sudo apt-get update (it is working fine)

After that when i do sudo apt-get upgrade this error is displaying:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 mariadb-server-10.3 : Depends: mariadb-client-10.3 (>= 1:10.3.34+maria~focal) but 1:10.3.34-0ubuntu0.20.04.1 is installed
 mariadb-server-core-10.3 : Breaks: mariadb-client-10.3 (< 1:10.3.34+maria~focal) but 1:10.3.34-0ubuntu0.20.04.1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I tried this command

sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libconfig-inifiles-perl
  libgstreamer-plugins-bad1.0-0 libva-wayland2
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  mariadb-client-10.3 mariadb-client-core-10.3
The following packages will be upgraded:
  mariadb-client-10.3 mariadb-client-core-10.3
2 upgraded, 0 newly installed, 0 to remove and 139 not upgraded.
4 not fully installed or removed.
Need to get 0 B/1,866 kB of archives.
After this operation, 20.1 MB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: regarding .../mariadb-client-core-10.3_1%3a10.3.34+maria~focal_amd64.deb c
ontaining mariadb-client-core-10.3:
 mariadb-client-10.3 conflicts with mysql-client-core-5.5
  mariadb-client-core-10.3 provides mysql-client-core-5.5 and is to be installed
.

dpkg: error processing archive /var/cache/apt/archives/mariadb-client-core-10.3_
1%3a10.3.34+maria~focal_amd64.deb (--unpack):
 conflicting packages - not installing mariadb-client-core-10.3
dpkg: regarding .../mariadb-client-10.3_1%3a10.3.34+maria~focal_amd64.deb contai
ning mariadb-client-10.3:
 mariadb-client-core-10.3 conflicts with mysql-client-5.5
  mariadb-client-10.3 provides mysql-client-5.5 and is to be installed.

dpkg: error processing archive /var/cache/apt/archives/mariadb-client-10.3_1%3a1
0.3.34+maria~focal_amd64.deb (--unpack):
 conflicting packages - not installing mariadb-client-10.3
Errors were encountered while processing:
 /var/cache/apt/archives/mariadb-client-core-10.3_1%3a10.3.34+maria~focal_amd64.
deb
 /var/cache/apt/archives/mariadb-client-10.3_1%3a10.3.34+maria~focal_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.