2

The server to which I am connecting is CentOS 7, the client is Windows 10. I am able to connect to an existing X session as remote desktop, but launching anything standalone, e.g. terminal or web browser does not work - the window is briefly opened, but then immediately closes afterwards and the session terminates.

There does not appear to be anything useful in the error logs - (nothing present in the file .xsession-x2go-hostname.errors). The logs of the session itself are below:

running as X2Go Agent
NXAGENT - Version 3.5.99.26

Copyright (c) 2001, 2011 NoMachine (http://www.nomachine.com)
Copyright (c) 2008-2014 Oleksandr Shneyder <[email protected]>  
Copyright (c) 2011-2016 Mike Gabriel <[email protected]>
Copyright (c) 2014-2016 Ulrich Sibiller <[email protected]>
Copyright (c) 2014-2016 Mihai Moldovan <[email protected]>
Copyright (c) 2015-2016 Qindel Group (http://www.qindel.com)
See https://github.com/ArcticaProject/nx-libs for more information.
Info: Agent running with pid '24336'.
Session: Starting session at 'Mon May 16 14:49:55 2022'.
Info: Proxy running in client mode with pid '24336'.
Info: Using errors file '/tmp/.x2go-user/C-user-97-1652705393_stRTERMINAL_dp32/session.log'.
Info: Using stats file '/tmp/.x2go-user/C-user-97-1652705393_stRTERMINAL_dp32/C-user-97-1652705393_stRTERMINAL_dp32/stats'.
Loop: WARNING! Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Warning: Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Info: Waiting for connection from 'localhost' on socket 'tcp:*:55494'.
Info: Accepted connection from '127.0.0.1'.
Info: Connection with remote proxy completed.
Info: Using ADSL link parameters 1408/24/1/0.
Info: Using agent parameters 5000/10/50/0/0.
Info: Using cache parameters 4/4096KB/8192KB/8192KB.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_32'.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Listening to X11 connections on display ':97'.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/0/0K.
Info: Using alpha channel in render extension.
Info: Not using local device configuration changes.
Warning: Cannot read keystroke file '/home/user/.x2go/config/keystrokes.cfg'.
Info: using keystrokes file '/etc/x2go/keystrokes.cfg'
Info: ignoring unknown keystroke action 'debug_tree'.
Info: ignoring unknown keystroke action 'regions_on_screen'.
Info: ignoring unknown keystroke action 'test_input'.
Info: ignoring unknown keystroke action 'deactivate_input_devices_grab'.
Currently known keystrokes:
  close_session         : Ctrl+Alt+t
  switch_all_screens    : Ctrl+Alt+f
  minimize              : Ctrl+Alt+m
  resize                : Ctrl+Alt+r
  defer                 : Ctrl+Alt+e
  ignore                : Ctrl+Alt+BackSpace
  force_synchronization : Ctrl+Alt+j
  fullscreen            : Ctrl+Shift+Alt+f
  viewport_move_left    : Ctrl+Shift+Alt+Left
  viewport_move_up      : Ctrl+Alt+Up
  viewport_move_right   : Ctrl+Alt+Right
  viewport_move_down    : Ctrl+Alt+Down
Info: keyboard blocking directory created: '/home/user/.x2go/C-user-97-1652705393_stRTERMINAL_dp32/keyboard'
Info: Keycode conversion is off
Session: Session started at 'Mon May 16 14:49:59 2022'.
Session: Terminating session at 'Mon May 16 14:50:03 2022'.
Info: Waiting the cleanup timeout to complete.
Session: Session terminated at 'Mon May 16 14:50:05 2022'.

How can I further debug this issue?

1 Answer 1

0

so I sort of have the same problem, but one thing I notice, is that if I rdp from windows to the server, something gets woken up such that the x2go client will then be able to connect to the server and display me a gui window. it won't start my display manager, so something's still wrong, but at least x2go will start a client window.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .