0

Working in a multicultural environment, I recently needed to switch the language displayed in my computer GUI (Debian 11 installed with Cinnamon). And I did not manage to do it easily!

I have been searching around for a while to find out how to add an additional language to my new Cinnamon installation. Obviously, reading from the internet, there should be a Languages icon in Cinnamon System Settings panel.

But this icon does not exist on my installation. Where did it go?

How can I have it back?

The workaround I used:

  • Close the Cinnamon session and open a Gnome session
  • Go to the Gnome system settings, choose the Country and Language menu, and select the language.
  • Then go back to a Cinnamon session

1 Answer 1

0

Cinnamon, has a standard plugin keyboard. You should add it on the panel.

In the System Settings, in section 'Hardware' look for the 'Keyboard'. It has a tab 'Layouts'.

There you can find a setting 'Use country flag to represent keyboard layout'. Unchecked - you would have two letters which represent language, checked - flag. The image comes from the keyboard plugin, so do not forget to add it.

On the same 'Layouts' page you will find layouts themselves. And a button 'Options' which will open a xkdb settings window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.