0

I have two hard drives, one with Ubuntu 22 (Jammy) and a separate drive with Windows 10. System boots to Ubuntu by default, as set in BIOS. I'm trying to get my grub boot menu to list the Windows 10 drive, as I previously had on Ubuntu 18.

  1. The Windows drive is mounted (visible and accessible in /media)
  2. ntfs-3g is installed

sudo os-prober still doesn't detect. Naturally, grub also fails (yes, I have GRUB_DISABLE_OS_PROBER=false)

Any ideas?

Boot-repair summary: https://paste.ubuntu.com/p/2bCVt7QPJY/

New contributor
EntangledLoops is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
8
  • Are both installed in same boot mode, probably with newer system both should be UEFI. Please copy & paste the pastebin link to the Bootinfo summary report ( do not post report), do not run the auto fix till reviewed.Lets see details, use ppa version with your USB installer (2nd option) or any working install, not Boot-Repair ISO help.ubuntu.com/community/Boot-Repair & sourceforge.net/p/boot-repair/home/Home
    – oldfred
    May 14 at 19:28
  • Added pastebin summary. Please note that the 2 nvme drives are the relevant ones (others are just externals). May 15 at 4:35
  • hmm can u tell me why you have windows in /media usually when you are dual booting grub only need to find efi for windows located in /boot/efi May 15 at 12:20
  • When I was trying to solve the same problem, I frequently saw advice to disable Fast Boot option in Windows May 15 at 13:34
  • It's only in /media because I opened the drive in Thunar (file manager) to view the files and ensure it is accessible. Idk if it automatically mounts there. May 15 at 17:47

0

Your Answer

EntangledLoops is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.