0

Here comes a strange question. I have a QT App and it requires some libraries. Normally, the following bash script works:

#!/bin/bash 
export LD_LIBRARY_PATH="./libs"
export QT_DEBUG_PLUGINS=1
./dataUI "$@" #This is the name of the APP

It works for my computer (Ubuntu 18), and in the WSL of my another device (Not equipped with QT IDE). However, as someone runs the script, the library files in the folder "./libs" cannot be found! (He uses Ubuntu 20 on WSL) The LD_LIBRARY_PATH does not seem to work. Any Hint on this problem?

5
  • Thanks! Actually, I tried absolute path on his computer, and it won't work. Also, he was using exactly the same copy of "libs". May 15 at 1:04
  • If you recompile the application on Ubuntu 20, does it work for your friend then?
    – Kusalananda
    May 18 at 6:02
  • I've tried to compile it with Ubuntu 20.04, which is the same version of Ubuntu as my friend's. Unfortunately, it didn't work. But now my friend find that this script can be executed in his virtual machine. Maybe there is something wrong with his WSL. Thanks any way:) May 19 at 7:41
  • So the issue disappeared?
    – Kusalananda
    May 19 at 10:43
  • Not in the WSL. The script works properly in his Virtualbox. May 20 at 11:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.