2

Environment:

OS: Fedora 36
DE: XFCE
Font: Windows Tahoma
Font config
$XDG_CURRENT_DESKTOP=XFCE
Qt6-6.2.3-2.fc36

Problem: Qt6 applications seemingly do not use my fontconfig settings (which are used for everything else, including XFCE, GTK2/3/4 and Qt3/4/5 applications, and web browsers).

I've used strace -e file and $HOME/.config/fontconfig/fonts.conf is indeed being read but it's not seemingly used correctly.

I do not see any error messages in console from Qt6 applications.

I have a suspicion something in terms of fonts support in Qt6 has changed drastically but I haven't been able to find anything.

Here's how Qt5 applications look like.

Here's how Qt6 applications look like.

I've filed a bug report because I haven't been able to find anything relevant.

0

1 Answer 1

0

This can be fixed by

export QT_ENABLE_HIGHDPI_SCALING=0

in e.g. /etc/profile.d/fix_qt6_fonts.sh

From the documentation for Qt6:

QT_ENABLE_HIGHDPI_SCALING Set to 0 to disable high-dpi scaling; effectively reverting to Qt 5 default behavior. Note that this has no effect on platforms such as Wayland or macOS - it does not disable any native high-DPI support. This variable is intended for testing purposes only, and we do not recommend setting it on a permanent basis.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .