0

I am trying to run the .exe of an app I have downloaded from the Apple store onto my virtual machine.

However, every time I run the file, I get the following error:

cannot execute binary file: Exec format error

I have found a few articles suggesting what to do when this error occurs.

I have tried the following:

  1. Installing Wine and then running the file with Wine. This gives me the alternative error found here. I could not solve this in the end.

  2. Run the following:

    chmod u+x StockSpy
    ./StockSpy
    

    This does not work either.

Here's the system information of my Linux machine:

Linux instance-5 5.10.0-13-cloud-amd64 #1 SMP Debian 5.10.106-1 (2022-03-17) x86_64 GNU/Linux
New contributor
Dollar X is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • In 1, what is the alternative error that you actually got? I've looked at the link and it's unclear which of the many messages it references is the one you're meaning. Please edit your question. Do not reply to me here in a comment
    – roaima
    May 14 at 9:00

1 Answer 1

2

The app is for an iPhone. Unless you have either a real iPhone or an emulator for one you're not going to be able to run it. wine is for Microsoft Windows emulation, not Apple iPhone

2
  • Ah I see! I was looking into possible options like Darling however, I was looking for the simplest solution that takes the least amount of hard-drive space. Unfortunately, Darling packs quite a punch. What other options do I have?
    – Dollar X
    May 14 at 9:27
  • I've no idea what Darling might be, sorry
    – roaima
    May 14 at 10:27

Your Answer

Dollar X is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.