1

I'm having a problem after installing Fedora 36.

I keep getting a half white screen while using an external monitor. I'm using my laptop and a monitor, but my monitor is only showing a white screen. When I hover my mouse to the monitor, it starts showing half screen. I dont get the message error anymore but the screen still half blank.


My laptop has an Nvidia RTX 2060 and a AMD Ryzen7 3750

[![enter image description here][1]][1]


  [1]: https://i.stack.imgur.com/HY3ZX.jpg
New contributor
rubencxtx is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1

1 Answer 1

0

The nouveau drivers are a bit "wonky". If you don't mind using proprietary drivers, you can enable them through the software center (if you're using GNOME); that will almost certainly solve your issue. If you're using Fedora 35/36 with GNOME, these are the steps:

  1. Open 'Software Center'.
  2. Click on the "hamburger menu" (top right corner, three horizontal lines).
  3. Select 'Software Repositories'.
  4. Scroll down until you see 'RPM Fusion for Fedora - Nonfree - NVIDIA Driver' and click to enable it.
  5. Close the 'Software Repositories' window and click on 'Updates' on the top bar of the 'Software Center'.
  6. Top left corner, click on the update icon (circled arrow) and wait for it to finish.
  7. Press on 'Explore' in the top bar and search for 'nvidia' and you will get the available packages.

If you are using a different DE or prefer installing the drivers through the CLI, these are the steps and (minimum required) packages you'll need to install:

  1. akmod-nvidia
  2. kmod-nvidia
  3. nvidia-modprobe
  4. xorg-x11-drv-nvidia (if you plan on using X11 instead of Wayland)

I haven't used Nvidia hardware in years, but I'm maybe the first two packages alone install everything you'll need to get up and running.

Good luck and you're welcome to ask or edit your question if this did not work.

EDIT: please try the following. Check if you have secure boot enabled, and if so, you'll have to disable it (if you don't know how to do it, Google your motherboard manufacturer/model). Then:

# dnf remove \*nvidia\*
# dnf install -y akmod-nvidia kernel-devel
# akmods --force
# dracut --force
$ shutdown -r

Please note that # means that the command is supposed to be executed with escalated privileges (i.e. sudo) and $ means not.

6
  • hey, thank you for your help, I've did what you told me with the CLI but it still the same, now whenI start fedora it says that the nvidia kernel module is missing, im new to linux and I'm loving it. how can I provide you with more information so you can now more about my problem?
    – rubencxtx
    May 14 at 17:10
  • @rubencxtx I've updated my answer. Please see if this works. I'm happy to hear that you're enjoying it! I was struggling myself in the beginning, coming from Windows, but if you stick with it and don't give up, I can promise you that you'll never want to go back ^_^
    – telometto
    May 15 at 8:49
  • hey man, thank you very much, i’m sorry but it does not worked :( when I start the laptop it says that the nvidia kernel module is missing, and after I did what you’ve told me in the edit my laptop started glitching, but thank you very much, idk if this help but i had fedora 35 and when I upgraded to fedora 36 I had my monitor working well, but when I installed the nvidia drivers it stoped working and every time I started the laptop it said that the nvidia kernel module was missing
    – rubencxtx
    May 15 at 23:40
  • I'm very sorry to hear that it didn't work :( It might be a problem with the drivers themselves... could you try and see if sudo dnf remove *nvidia* && sudo dnf install akmod-nvidia-470xx works? Maybe downgrading the driver will sort things out. Also did you check if you had secure boot enabled?
    – telometto
    May 16 at 0:03
  • yup, i have it enable, I did what you've told me again and it doesn't waork eaither :( maybe if I try to download fedora 35 then upgrade to fedora 36, do you think it will work? because when I upgraded to fedora 36 from fedora 35 my monitor was working fine. Again thank you for you help
    – rubencxtx
    2 days ago

Your Answer

rubencxtx is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.