0

i try to open a terminal using gnome-terminal after system reboot,so i used the gnome-terminal in crontab.In normal cron it works. ex : */1 * * * * export DISPLAY=:0 && gnome-terminal but used with reboot option,it doesn't work @reboot export DISPLAY=:0 && gnome-terminal Is there any way to achieve this?

New contributor
Ranjith is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • I'm using Ubuntu 20.04,there is no autostart directory under .config.
    – Ranjith
    May 14 at 6:14

1 Answer 1

0

I achieved this without using cron.

Just following these steps:

  1. Type "Startup Applications" in the search bar.

  2. Click on the Startup Applications option. Then click "Add".

  3. In the "name" field, type Terminal.

  4. In the "command" field, type gnome-terminal.

  5. Click "Add".

You're done! The next time you login, the terminal will launched automatically.

New contributor
Ranjith is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Ranjith is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.