1

Debian 11 here with LXDE (Xorg + lightdm)

How could I change the driver used by X?

My X is using the default options, I have no /etc/X11/xorg.conf file, so I generate one with the command sudo X -configure :1 and after that copying the contents of /root/xorg.conf.new to /etc/X11/xorg.conf

After reboot I have a running X on :0 like before (ps auxww | grep Xorg returns ... /usr/lib/xorg/Xorg -s 0 :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch), but with a blank screen (no EE in /var/log/Xorg.0.log file). If I remove that /etc/X11/xorg.conf file and reboot I have a normal screen again.

The generated /root/xorg.conf.new is this (removed commented options, some FontPaths and SubSections Display's, for brevity)

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"

    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Noticed that without an /etc/X11/xorg.conf file the output names returned by xrandr have a dash, like DP-1, DP-2 etc and with that file xrandr return those names without a dash: DP1, DP2...

The only change I want to do is replace:

Driver "intel"

with

Driver "fbdev"

Already tried to remove the xserver-xorg-video-intel package but it would break my system removing the WM, DE and a lot of other apps.

3
  • Are you running a standard Debian kernel or a customized one? If you run cat /proc/fb, what does it say? Have you installed the xserver-xorg-video-fbdev package? Without that package, setting Driver "fbdev" will not work, and the X server will then automatically try and find other drivers that might work. Instead of creating /etc/X11/xorg.conf, you might try taking just the Section "Device"... EndSection part from /root/xorg.conf.new and place just that part into e.g. /etc/X11/xorg.conf.d/device.conf, letting the X server auto-detect the rest.
    – telcoM
    May 12, 2022 at 18:03
  • Thank you for your reply @telcoM: Standard kernel, cat /proc/fb returns: 0 radeondrmfb, xserver-xorg-video-fbdev package is installed, tried to place just the Section "Device" part in a file inside /etc/X11/xorg.conf.d but without success, tried to specify a custom xorg.conf, with the xserver-config parameter of /etc/lightdm/lightdm.conf file, set but the same blank screen happen too. Even with the original xorg.conf.new generated, without any changes, placed in /etc/X11/xorg.conf I have a blank screen.
    – igorkattar
    May 12, 2022 at 18:18
  • Sorry @telcoM, as I explained in the edit and in the answer, I mixed machines while researching this, so, to correct my answer in your first question the output of cat /proc/fb is: 0 i915drmfb the other ones are the same: packages installed and configuration files placed in different directories.
    – igorkattar
    May 13, 2022 at 13:33

1 Answer 1

0

A little confusion by my side, so I have to make the appropriate corrections to get in, I think, a somewhat good explanation.

I'm working on several machines trying to make that driver change, and I mixed the results with the machine with radeon driver and the machine with the intel driver, my bad.

The problem is that the intel driver (xserver-xorg-video-intel, not radeon, fixed already) does not generate output names with the dash (DP1), when using the /etc/X11/xorg.conf file, but without that file those names are generated with the dashes (DP-1) and since my screens are configured using a set of xrandr scripts, generated when I was using an Xorg without a /etc/X11/xorg.conf file, that script could not set my screens.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .