0

I am attempting to mount a shared drive located on a 2019 windows server(192.168.1.180) to my linux machine(Ubuntu 18.04). I've updated my fstab as you can see below and created a new directory for the mount (/mnt/remotebackupswintest). The shared drive only allows certain users but I am able to ping the device. I am also able to map the drive on my windows machine with the appropriate credentials; however, I am thinking that I probably did something wrong. I am not well versed in Linux so room for error is expected. Not sure if I am missing a domain or another option in my fstab or mount cmd but any help is greatly appreciated. Thank you all so much.

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation`
UUID=0b903abc-2db7-4b0d-a7e2-b04a2a6e9f34 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=369D-A7AB  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
UUID=8cdd9989-b101-4504-ae59-e6b9d1ccba7b       /mnt/sdb        ext4    defaults        0       2
UUID=5674cc07-064a-44e9-82c6-01a501cd8fba       /mnt/sdc        ext4    defaults        0       2
//192.168.1.180/glservertest /mnt/remotebackupswintest cifs  vers=1.0,user=user_1

I run the following command: root@glserver:/# sudo mount.cifs //192.168.1.180/glservertest /mnt/remotebackupswintest user=user_1, -o version=1.0

I receive this error: mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

The log info says this: May 10 11:05:54 localhost kernel: [2847286.234589] CIFS: Unknown mount option "version=1.0" Note: Windows server has SMB 1.0/CIFS is installed.

EDIT: just tried vers= instead of version= and it produced the following error:

May 10 14:37:24 localhost kernel: [2859976.122955] CIFS VFS: Send error in SessSetup = -13
May 10 14:37:24 localhost kernel: [2859976.122999] CIFS VFS: cifs_mount failed w/return code = -13

EDIT 2: I took away the vers= but now I am getting a Device or resource busy

Command used: root@glserver:/# sudo mount.cifs //192.168.1.180/glservertest /mnt/remotebackupswintest -o user=user_1

Error: May 10 15:55:27 localhost kernel: [2864659.611981] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

May 10 15:55:27 localhost kernel: [2864659.614555] CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-5

8
  • The error says that there is no option version=. See man page man mount.cifs. There is a vers=, try with that.
    – thanasisp
    May 10, 2022 at 19:45
  • Ok thank you. I tried that but i get a permission denied... My credentials are correct. What else could it possibly be? Thanks!
    – dakota_man
    May 10, 2022 at 20:38
  • You could check following this post: unix.stackexchange.com/questions/124342/…
    – thanasisp
    May 10, 2022 at 20:47
  • Very helpful. Unfortunately, this is new for me and i don't have the first clue where our credentials are stored. We have a hybrid O365 environment.
    – dakota_man
    May 10, 2022 at 21:03
  • 1
    That may also just be a warning. Have you verified that the share actually didn't mount? Instead of doing it manually, you can also just remove vers=1 from /etc/fstab and just use the command mount -a. You don't need to prepend sudo to any commands as you are already in a root shell. May 10, 2022 at 22:07

1 Answer 1

0

Removing the version= and making it Read/Write access to everyone resolved my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .