0

I am trying to play back a dash manifest using ffmpeg but I keep running into the issue of ffmpeg ending with the error

[http @ 0x671e580] Stream ends prematurely at 2250, should be 18446744073709551615

The dash manifest is for a livestream.

I have tested the live stream in VLC player on Windows and MX player on Android and it plays perfectly fine.  The issue seems to be just with ffmpeg.

Has anyone had this issue before or know what the cause may be?

I have tried telling ffmpeg to reconnect but it just loops this error.  I have tried two different MPD live streams:

  • $Time$ based, and
  • $Number$ based

The issue happens only with the Number based live stream.

1 Answer 1

0

Hi did you find a solution to this issue i have an mpd that plays perfect in everything vlc/mx/exo/shaka player the lot but it refuses to open in ffplay and ffmpeg i get the same error as you followed by io/error unable to read manifest

i have tested the manifest against the online dash validation tools and it passes with no problems and works with everything but ffmpeg

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .