OS: Parrot Sec (Debian based)

I'm unable to install winehq-staging package because installing wine-staging-i386 keeps throwing dependency errors at me. This is how it looks:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libc6:i386 (>= 2.35) but 2.31-13+deb11u3 is to be installed
                          Depends: libldap-2.5-0:i386 (>= 2.5.4) but it is not installable
                          Recommends: libgtk-3-0:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've tried:

  • apt install -t parrot-backports
  • installing mentioned packets like libgtk-3-0:i386 (installation failed)
  • installing libasound2-plugins:i386 (installation succeeded)

Any help will be appreciated :)

1 Answer 1


You’re trying to install a version of Wine Staging built for a distribution which doesn’t match yours. Since Parrot Security is based on Debian stable (currently, Debian 11), you need to follow the Debian 11 instructions for Wine:

wget -nc https://dl.winehq.org/wine-builds/debian/dists/bullseye/winehq-bullseye.sources
sudo mv winehq-bullseye.sources /etc/apt/sources.list.d/

If you have any other WineHQ repositories configured, you should remove the corresponding files from /etc/apt/sources.list.d.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .