1

I've started the Ubuntu Server 22.04 installation on my Dell R210 II, but right after displaying a few pages of text the monitor goes black, then displays the message input signal out of range.
I've worked around this by editing and adding nomodeset in GRUB at the end of the linux line. Now the installer goes further, but shows this error and would not continue ubuntu server probing for devices to install to failed
Here I've got stuck and could not find anything relevant to go further (or at least for my level on knowledge :-))

I've decided to install Ubuntu Server 20.04, then upgrade to 22.04 later, thinking I might bypass the probing error this way. The Ubuntu Server 20.04 installation went fine without issues, then I have upgraded to 22.04, but after the restart I get again the input signal out of range message on my monitor.

I think something goes wrong because I can't ssh into the system, so clearly it does not fully boot.

I would appreciate your help to make 22.04 work on my server, if possible.
Is there a way to make a change in how Ubuntu starts and add something like nomodeset as I dit before for the installer?

I have the upgraded 22.04 on one drive and another 20.04 on another if this helps. I don't have any other hardware beside the Dell R210 II motherboard with the on board GPU

3
  • 1
    Are you using the onboard Matrox G200eW video card, or do you have an add on video card?
    – user10489
    Commented May 8, 2022 at 0:59
  • 1
    Does this help? askubuntu.com/questions/1231887/…
    – user10489
    Commented May 8, 2022 at 1:04
  • Thanks, yes, I'm using the onboard Matrox G200eW and it seems to be a driver issue. I will try the recommendations from the link you have shared.
    – Ionut
    Commented May 8, 2022 at 17:31

2 Answers 2

1

I've managed to make it work using the low resolution with @user10489 suggestion from https://askubuntu.com/a/1241370/498148

  1. start Ubuntu once with the nomodeset parameter
    in GRUB edit the first option and add nomodeset at the end of the linux line
  2. persist the nomodeset parameter
    once Ubuntu started, edit the /etc/default/grub file and at the end of GRUB_CMDLINE_LINUX_DEFAULT value add nomodeset like
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

more details here https://ubuntuforums.org/showthread.php?t=1613132

1

The "signal input is out of range" issue is easily resolved. The problem is twofold. This occurs during installation and upgrade.

So from Ubuntu 12.04, 14.04, 16.04, 18.04, 20.04, and 22.04, the resolution setting was moved from the start-up manager to the kernel. Before, it was solved using Startup-Manager, but since “Startup-Manager is dead,” it was dropped from Ubuntu 12.04’s repository.

Start your boot device during installation, press F6 only select ACPI and nomodeset and continue with installation in safe graphics.

In Simple steps

sudo nano/etc/default/grub

find the line;

#GRUB_GFXMODE=640x480

Remove the # and change 640x480 to the preferred mode you have with your monitor. e.g 1024x768, 1280x1024, and 1600x900.

Then find grub command line setting;

Add nomodeset to the GRUB_CMDLINE_LINUX_DEFAULT value as shown below.

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

Save, then type

sudo update-grub

You need also to update your OS after updating grub

sudo apt update

You can also follow all of the steps here, which saved me months of searching online for my old desktop computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .