1

I recently configured a new web server (AWS EC2 instance) running Ubuntu 22.04. I am able to connect to the server via SSH/SFTP/SCP through a CLI on both Windows and Mac, but when I attempt an SFTP connection via a GUI (WinSCP on Windows; Commander One on Mac) my authentication is refused. I am using a private-key connection without a password, and the same exact key is being used in the CLI and in the GUI.

On the remote Ubuntu Server I am running byobu but I have tried disabling it (as byobu modified my .bashrc and .profile), and that has not fixed the problem.

I have a number of other servers all running different versions of Ubuntu (the problem server is the only one on 22.04), all of them have byobu enabled, and there are no issues connecting to them via SSH or GUI SFTP.

Maybe something changed in the latest version of OpenSSH and OpenSSL on Ubuntu 22.04? The versions installed on Ubuntu 22.04 are OpenSSH_8.9p1 Ubuntu-3 & OpenSSL 3.0.2 15 Mar 2022.

I have also added PubkeyAcceptedKeyTypes=+ssh-dss to my sshd_config file, but that has not helped.

Lastly, I had UFW running, but have disabled it and that has not changed anything.

0

2 Answers 2

1

Per @MartinPrikryl (developer of WinSCP) I tried the 5.20.x beta version of WinSCP and that worked. Looks like Ubuntu 22.04 must be using newer protocol versions that GUI clients have not fully updated to.

0

I'm in the exact same situation as you (our setup is virtually the same) and I'm getting the exact same error message. I opened a support ticket on AWS and I received the following response:

So, I would like to mention that I was able to replicate the situation in the Lab environment and I was successfully able to connect to the SFTP on a Ubuntu 22.04 LTS version. The AMI I used for the Ubuntu image is ami-09d56f8956ab235b3 and provisioned the instance in the us-east-1 region. The client I used to connect to test the SFTP was “Mac Terminal” using below command:

sftp -i /location of pem file/ ubuntu@xx.xx.xx.xx

I did not encounter any “Unable to authenticate” error when connecting to the server. Further I would like to mention that we do not have the permission to update the Ubuntu images hosted on AWS as they are managed by the vendor.

1
  • hopefully someone has a solution for us. It seems like your contact at AWS didn't make much headway as neither of us are having issues with CLI access (Mac Terminal being a CLI interface). It's when we get to GUIs (like Cyberduck, Filezilla, etc) that we are having issues. May 9 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.