0

I am running transmission-remote and want all new torrent downloads to be created with g+w permissions.

The transmission Downloads directory is symlinked to a Downloads directory on a second drive

as user stephen ( a member of the transmission group ) I can run

 [stephen@flip:/mnt/sdb/Downloads]
 :> umask g+w .

 [stephen@flip:/mnt/sdb/Downloads]
 :> umask -S
 u=rwx,g=rwx,o=rx

which seems to be successful, however transmission is creating new directories with drwxr-xr-x

I suppose I should run the umask command as transmission, but that is a nologin user probably for good reason so I'll try sudo ...

:> sudo -u transmission umask g+w .
sudo: umask: command not found

okay so I'll call umask through its path but :

[stephen@flip:/mnt/sdb/Downloads]
:> which umask
which: no umask in <PATH>

[stephen@flip:/mnt/sdb/Downloads]
:> alias umask
bash: alias: umask: not found

What can/should I do?

4
  • 1
    What is your umask setting in your settings.json file?
    – Jim L.
    May 4 at 18:40
  • 1
    the file creation mask is inherited from parent process to child process, it's not per-user (the same as environment variables and group memberships etc.). So you can't usefully change it from an external program, like an umask command that would be in PATH. You either need to change the umask of the server process, or use default ACLs
    – ilkkachu
    May 4 at 19:12
  • @JimL. Ah. "umask": 18, May 4 at 19:19
  • @ilkkachu Thanks! That explains a lot. May 4 at 19:21

1 Answer 1

3

Per this answer, you need to change your settings.json file.

Where you have:

umask 18

you need:

umask 2

Be certain to restart the transmission daemon after making that change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.