2

I've noticed that there is a big feature missing on Wayland/Gnome/Linux in general regarding mouse input. In almost all applications that incorporate a WebView (Discord, Spotify, all Browsers) and many other applications I can scroll by clicking the scroll wheel and moving my mouse on Windows. I've found a workaround for xorg through this answer. This workaround works like this: hold the middle click for about one second and the move the mouse and that it worked fine until I tried Wayland, since Wayland uses libinput and not xinput.

So my question is: Is there any way to emulate one of the above-mentioned behaviors for Wayland?

I already tried clicking the Link in the answer, but it just leads me to an 404 Error page.

1 Answer 1

1

That is called "autoscrolling" and it's not actually a Windows feature but a feature implemented by those browsers, which they disable by default on Linux.

In Firefox, you can enable it by going into Settings, scrolling down to Browsing and ticking the "Autoscroll" box. Alternatively you can enable general.autoScroll in about:config, and likely you will also want to disable middlemouse.paste while you're here to not paste sensitive information to random webpages (which can and will be listening to it using JavaScript, even if there is no visible form).

In Chrome/Electron, it seems you can enable middle-mouse autoscrolling by passing the --enable-blink-features=MiddleClickAutoscroll command line parameter. This does not work in all Electron apps though.

PS: On Wayland, at least in KDE, it is (finally!) possible to disable middle-mouse pasting system-wide in the system settings app. I do not know if this is the case on Gnome, but there is at least no longer an X11-level technical limitation in place preventing this feature from existing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .